Uploaded image for project: 'Apache Flex'
  1. Apache Flex
  2. FLEX-32414

Localisation (localization) steps as perscribed in the Flex help fail when using AdvancedDataGrid or charting.

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • Adobe Flex SDK 3.1 (Release)
    • Adobe Flex SDK Previous
    • Advanced Data Grid
    • None
    • Affected OS(s): All OS Platforms
      Affected OS(s): All OS Platforms
      Language Found: English

    Description

      Steps to reproduce:

      1. Run the "copylocale en_US de_DE" command of Flex SDK 3.1 successfully - no errors reported.
      2. Create a project that uses for example the component "mx:AdvancedDataGrid"
      3. Created a folder /locale/de_DE, add properties file with name/value pairs.
      4. Add the resource bundle to the application using the meta tag [ResourceBundle( "xxx.properties" )
      5. Add -locale=de_DE to the compiler options of Flex builder.
      6. Add locale/

      {locale}

      to the project's source path.

      Actual Results:
      Compiler error as follows:
      Unable to resolve resource bundle "datamanagement" for locale "de_DE".

      Expected Results:
      No compiler errors.

      Workaround (if any):

      Other comments:

      Attachments

        Activity

          People

            adobejira Adobe JIRA
            adobejira Adobe JIRA
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: