Apache Flex
  1. Apache Flex
  2. FLEX-28568

RTE loading font style module in sub-application when SWFLoader.loadForCompatibility is used

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: Adobe Flex SDK Previous
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Affected OS(s): All OS Platforms
      Affected OS(s): All OS Platforms
      Language Found: English

      Description

      Steps to reproduce:
      1. Open provided zip file
      2. launch 'myMainApp.html' in the bin-debug folder
      3. The main application will load the sub-application 'mySubApp.swf'
      4. 'mySubApp.swf' will load in a font style module created from CSS called 'en_US_Fonts.swf'

      Actual Results:
      The following RTE is displayed:

      ArgumentError: Error #1508: The value specified for argument font is invalid.
      at flash.text::Font$/registerFont()
      at en_US_Fonts/setStyleDeclarations()[C:\DEVELOPMENT\workspace_flex45\SUBAPP_FONT_LOADING\bin-debug\generated\en_US_Fonts-generated.as:85]
      at Function/<anonymous>()[E:\dev\hero_private\frameworks\projects\framework\src\mx\styles\StyleManagerImpl.as:1522]
      at flash.events::EventDispatcher/dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      at ModuleInfoProxy/moduleEventHandler()[E:\dev\hero_private\frameworks\projects\framework\src\mx\modules\ModuleManager.as:1149]
      at flash.events::EventDispatcher/dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      at ModuleInfo/readyHandler()[E:\dev\hero_private\frameworks\projects\framework\src\mx\modules\ModuleManager.as:793]
      at flash.events::EventDispatcher/dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      at mx.core::FlexModuleFactory/update()[E:\dev\hero_private\frameworks\projects\framework\src\mx\core\FlexModuleFactory.as:535]
      at mx.core::FlexModuleFactory/docFrameHandler()[E:\dev\hero_private\frameworks\projects\framework\src\mx\core\FlexModuleFactory.as:681]
      at mx.core::FlexModuleFactory/docFrameListener()[E:\dev\hero_private\frameworks\projects\framework\src\mx\core\FlexModuleFactory.as:131]

      Expected Results:
      No RTE is displayed and font is applied only to the sub-application since loadForCompatibility is used so the font should be in the sub-applications applicationDomain.

      Workaround (if any):
      None known

        Activity

        Adobe JIRA added a comment -

        On 2011-09-21 14:06:39.315 aclaypoole commented:
        After discussing this issue on the Adobe Forum (http://forums.adobe.com/message/3929699) with Alex Harui he suggested I upload the latest testbed whereby I tried using a font embedded in a <s:Module> and loading that via the Sub-application. While the RTE doesn't occur (because Font.registerFont is not used) the font from the Module does not get applied to certain types of controls. The ones identified thusfar are RichEditableText and TextArea. This even occurs when launching the Sub-application standalone.
        On 2011-09-27 13:49:29.546 aclaypoole commented:
        Any update on this issue from a 'bug' perspective? Seems to me their either has to be a fix to not include 'Font.registerFont' in SWFs generated from CSS or work on the Flash Player side to allow 'Font.registerFont' to happen across ApplicationDomains.
        On 2011-09-28 14:21:21.864 jacobg commented:
        I can reproduce this issue
        This is not a regression
        To Internal Review
        On 2011-09-29 11:40:12.415 tvoliter commented:
        IRB: Investigate to Alex.

        Alex, we are considering this for Mega. Can you investigate and provide more info about the scope, impact, and cost of fixing the bug? Thanks.
        On 2011-09-29 23:57:35.551 aharui commented:
        Player bug. Will file bug shortly.
        On 2011-09-30 10:38:25.583 lmcliste commented:
        Senorita A - Ultra external tracking

        Adobe JIRA added a comment -

        created: 2011-09-19 14:07:26.000
        updated: 2011-10-07 09:38:59.000

        Adobe JIRA added a comment -

        Adobe Bug URL: http://bugs.adobe.com/jira/browse/SDK-31597
        Original Reporter: aclaypoole
        Original Resolution: Not a Bug
        Discoverability: High
        Number of votes: 7
        Regression: No
        Reproducibility: Every Time
        Severity: Runtime Error
        reporter: aclaypoole


          People

          • Assignee:
            Unassigned
            Reporter:
            Adobe JIRA
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Development