Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: Adobe Flex SDK 3.3 (Release)
    • Fix Version/s: None
    • Component/s: mx: DataGrid
    • Labels:
      None
    • Environment:
      Affected OS(s): Windows
      Affected OS(s): Windows XP
      Browser: Firefox 3.x
      Language Found: English

      Description

      Steps to reproduce:
      1. Import attached test case and run it.
      2. Double click a row of the DataGrid as close to the edge between row as possible. I think you have to be within 1 or 2 pixels of the edge.

      Actual Results:
      You will see two ItemClick events.

      Expected Results:
      One ItemClick event, and one ItemDoubleClick event.

      Workaround (if any):
      We're not using one, but I suppose you could create a Timer, and if you get two ItemClicks within... 300ms, then dispatch an ItemDoubleClick.

        Activity

        Adobe JIRA created issue -
        Adobe JIRA added a comment -

        Adobe Bug URL: http://bugs.adobe.com/jira/browse/SDK-23532
        Original Reporter: gtb104
        Discoverability: High
        Number of votes: 1
        Reproducibility: Every Time
        Severity: Incorrectly Functioning
        reporter: gtb104

        Adobe JIRA added a comment -

        created: 2009-09-30 14:31:39.000
        updated: 2010-07-19 00:53:54.000

        Adobe JIRA made changes -
        Field Original Value New Value
        Attachment Test.fxp [ 25127 ]
        Adobe JIRA made changes -
        Project Import Wed Feb 08 07:56:03 PST 2012 [ 1328716563210 ]
        Tony Stevenson made changes -
        Project Import Sat Jun 16 17:29:08 UTC 2012 [ 1339867748525 ]
        Mark Kessler made changes -
        Assignee Mark Kessler [ paeros ]
        Mark Kessler added a comment -

        Tested using below app. Cannot reproduce bug with latest Flex-SDK.

        <?xml version="1.0" encoding="utf-8"?>
        <!---
        Test application
        -->
        <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"
        xmlns:s="library://ns.adobe.com/flex/spark"
        xmlns:mx="library://ns.adobe.com/flex/mx" >

        <fx:Script>
        <![CDATA[
        import mx.events.ListEvent;
        import mx.collections.ArrayCollection;

        [Bindable]
        private var __dgData:ArrayCollection = new ArrayCollection([

        {label:"AA", data:"AAA"}

        ,

        {label:"BB", data:"BBB"}

        ,

        {label:"CC", data:"CCC"}

        ,

        {label:"DD", data:"DDD"}

        ,

        {label:"EE", data:"EEE"}

        ,

        {label:"FF", data:"FFF"}

        ,

        {label:"GG", data:"GGG"}

        ]);

        protected function onItemClick( event:ListEvent ):void

        { ta.text += "itemClick\n"; }

        protected function onItemDoubleClick( event:ListEvent ):void

        { ta.text += "itemDoubleClick\n\n"; }

        ]]>
        </fx:Script>

        <s:layout>
        <s:VerticalLayout horizontalAlign="center" verticalAlign="middle" gap="0" />
        </s:layout>

        <mx:DataGrid id="dg" dataProvider="{__dgData}" width="200"
        allowMultipleSelection="true" doubleClickEnabled="true"
        itemClick="onItemClick(event)" itemDoubleClick="onItemDoubleClick(event)">
        </mx:DataGrid>

        <mx:TextArea id="ta" height="400" width="400"/>

        </s:Application>

        Mark Kessler made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Not A Problem [ 8 ]
        Mark Kessler made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1298d 7h 28m 1 Mark Kessler 20/Apr/13 23:00
        Resolved Resolved Closed Closed
        5s 1 Mark Kessler 20/Apr/13 23:00

          People

          • Assignee:
            Mark Kessler
            Reporter:
            Adobe JIRA
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development