Uploaded image for project: 'Apache Fineract'
  1. Apache Fineract
  2. FINERACT-804

Use OkHTTP v3 or at least 2.7.5 instead of 2.0.0

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0
    • Component/s: None
    • Labels:
      None

      Description

      This came up during (the review of) FINERACT-797:

      The Spring Boot BOM uses OkHTTP v3, whereas Fineract currently has a fixed 2.0.0.

      The goal of this issue would be to drop the version number of OkHTTP in Fineract's Gradle dependencies list, so that we simply inherit whichever (latest) one our use of Spring Boot BOM, introduced in FINERACT-797, gives us.

      It's possible that the change from OkHTTP v2 to v3 requires some code changes (not checked).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                natashan Natasha Natarajan
                Reporter:
                vorburger Michael Vorburger
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: