Uploaded image for project: 'Commons FileUpload'
  1. Commons FileUpload
  2. FILEUPLOAD-203

Processing of multipart/form-data request failed. Async operation timed out

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      AIX

      Description

      We are seeing the below exception when we do the load testing with our application. Please let us know any reason why this exception is appeared and also please let us know for any fixes needed to avoid this?

      [12-05-11-10:05:05] 495837912 [WebContainer : 6] ERROR com.ibm.dolphin.webengine.lifecycle.plugins.ServletManagerPlugin - servlet exception root cause:
      org.apache.commons.fileupload.FileUploadException: Processing of multipart/form-data request failed. Async operation timed out
      at org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.java:384)
      at org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.java:268)
      at org.apache.struts.upload.CommonsMultipartRequestHandler.handleRequest(CommonsMultipartRequestHandler.java:182)
      at org.apache.struts.util.RequestUtils.populate(RequestUtils.java:389)
      at org.apache.struts.action.RequestProcessor.processPopulate(RequestProcessor.java:794)
      at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:191)
      at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1858)
      at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:459)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:711)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:831)
      at com.ibm.dolphin.webengine.lifecycle.plugins.ServletManagerPlugin.handleRequest(ServletManagerPlugin.java:117)
      at com.ibm.dolphin.webengine.lifecycle.LifecycleManager.processLifecycleRequest(LifecycleManager.java:225)
      at com.ibm.dolphin.webengine.servlet.DRLProxyServlet.service(DRLProxyServlet.java:90)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1657)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:939)
      at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:502)
      at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.handleRequest(ServletWrapperImpl.java:179)
      at com.ibm.ws.webcontainer.servlet.CacheServletWrapper.handleRequest(CacheServletWrapper.java:91)
      at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:864)
      at com.ibm.ws.webcontainer.WSWebContainer.handleRequest(WSWebContainer.java:1583)
      at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:186)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:452)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewRequest(HttpInboundLink.java:511)
      at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.processRequest(HttpInboundLink.java:305)
      at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:83)
      at com.ibm.ws.ssl.channel.impl.SSLReadServiceContext$SSLReadCompletedCallback.complete(SSLReadServiceContext.java:1784)
      at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
      at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
      at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)
      at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:138)
      at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:204)
      at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:775)
      at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)
      at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)

        Activity

        chtompki Rob Tompkins added a comment -

        can't reproduce.

        simone.tripodi Simone Tripodi added a comment -

        There's no way to reproduce that issue, marking it as Cannot Reproduce, feel free to reopen it as soon as you can submit a testcase which demonstrates the issue.
        TIA!

        tn Thomas Neidhart added a comment -

        This is most likely related to your webcontainer (Websphere in this case).
        The error happens when the input stream is processed and it takes longer than the default timeout of 300s. Please check your settings.


          People

          • Assignee:
            simone.tripodi Simone Tripodi
            Reporter:
            sgkishore Gopi K Swamy
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development