Uploaded image for project: 'Felix'
  1. Felix
  2. FELIX-5888

OBR does not properly hanle Bundle-RequiredExecutionEnvironment header

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: bundlerepository-2.0.10
    • Fix Version/s: None
    • Labels:
      None

      Description

      I found this problem while trying to load slf4j using bundlerepository 2.0.10 and framework 6.0.0

      SLF4J contains (obsolete I think) manifest entry
      Bundle-RequiredExecutionEnvironment: J2SE-1.5
      which later on translates into (ee=J2SE-1.5) requirement which is not supported by the framework. As far as I have seen in framework resolver, J2SE is on-the-fly translated into JavaSE requireent which is now providedby the framework.

      Not doing so, framework loads these bundles properly (e.g. using fileinstall, but trying to deploy these artifacts using resolver that comes from bundlerepository e.g. using the following procedure 

      Resolver resolver = repositoryAdmin.resolver();
      resolver.addResource(...)
      resolver.resolve();
      resolver.deploy(Resolver.START);

      fails with missing requirement:
      requires=ee, condition=(|(ee=J2SE-1.5)), E=false, M=false, O=false: Execution Environment (|(ee=J2SE-1.5))

       

      Possible solution attached.

       

        Attachments

        1. javase.patch
          3 kB
          Marek Budyn

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              neg Marek Budyn
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: