Felix
  1. Felix
  2. FELIX-4293

[DS] logic error in handling configuration LOCATION_CHANGED event

    Details

      Description

      Pierre de Rop found this with a stack trace like:

      ava.lang.NullPointerException
      at
      org.apache.felix.scr.impl.manager.ComponentFactoryImpl.getProperties(ComponentFactoryImpl.java:226)
      at
      org.apache.felix.scr.impl.manager.ComponentFactoryImpl.configurationUpdated(ComponentFactoryImpl.java:396)
      at
      org.apache.felix.scr.impl.config.ConfigurationSupport.configurationEvent(ConfigurationSupport.java:390)
      at

      The problem occurs because I didn't adapt the code well enough to broken config admin implementations.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        8h 57m 1 David Jencks 26/Oct/13 08:41
        Resolved Resolved Closed Closed
        313d 22m 1 Carsten Ziegeler 04/Sep/14 09:04
        Carsten Ziegeler made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        David Jencks added a comment -

        Pierre reports the problem is still there. It looks like CM_LOCATION_CHANGE events are supposed to be sent out even before there are any properties set. In rev 1536005 I added some code to ignore these events.

        David Jencks made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        David Jencks added a comment -

        rev 1535941

        I basically reversed many of the changes in felix-3651 rev 1480108 except now extracting the info we need from the Configuration before ungetting the config admin instance. This makes the logic flow a little clearer.

        David Jencks created issue -

          People

          • Assignee:
            David Jencks
            Reporter:
            David Jencks
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development