Uploaded image for project: 'Felix'
  1. Felix
  2. FELIX-3058

maven-bundle-plugin 2.3.5 incompatible with maven-source-plugin (regression)

    XMLWordPrintableJSON

    Details

      Description

      Since version 2.3.5 the maven-bundle-plugin is incompatible with the maven-source-plugin. I get the following error message during the maven-sources-plugin:jar goal:
      [WARNING] NOT adding sources to artifacts with classifier as Maven only supports one classifier per artifact. Current artifact [<GroupId>:<ArtifactId>:<Version>] has a [] classifier.

      The problem does not occur with maven-bundle-plugin in version 2.3.4.

      You can easily reproduce by creating a project with packaging "bundle" and just configuring the maven-source-plugin like this:

      <plugin>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-source-plugin</artifactId>
      <version>2.1.2</version>
      <executions>
      <execution>
      <id>attach-sources</id>
      <goals>
      <goal>jar</goal>
      </goals>
      </execution>
      </executions>
      </plugin>

        Attachments

        1. patch
          0.5 kB
          Arik Kfir

          Activity

            People

            • Assignee:
              mcculls Stuart McCulloch
              Reporter:
              kwin Konrad Windszus
            • Votes:
              5 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: