Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.4-FINAL
    • Component/s: None
    • Labels:

      Description

      Ext-Scripting is an extension framework for the Apache MyFaces project, its goal is to provide scripting language support and dynamic recompilation and reloading (hotplugging) within JSF.

      The long term goal of Ext-Scripting is to have support for most major frameworks which have hooks into Ext-Scripting.
      The near term goal is Spring and CDI.
      While spring support is being worked for in the inofficial 1.1 branch,
      CDI is an open issue, which might be resolvable in the GSOC 2010.

      The goal would be to support both implementations within our Ext-Scripting infrastructure.

      Following goals have to be reached:

      a) Determine which extension points in the implementations can be used to hook ext-scripting in, and provide a prototype for a simple reload
      of a single class within those extensions (by using a throw away classloader, but without recompile)

      b) Provide a neutral easy to use APIs for framework extensions (that would be a separate issue outside of what should be done within GSOC since it has to be done before summer) for 1.1

      c) Implement one of those extensions for at least one implemtation, if time allows for both

        Activity

        Werner Punz added a comment -

        I would be willing to mentor this project for GSOC 2010

        Werner Punz added a comment -

        adding gsoc labels

        Werner Punz added a comment -

        The GSOC Project has reached ists goal and this is satisfactory, but the problem is, that it cannot deal with custom scopes and only works with owb and its integrated scopes. The better bet after consulting the owb people is, to simply restart the container at changes. We do not get the fine grained granularity as with jsf beans but this is a neutral way which in the long run also will work with Weld.

        Werner Punz added a comment - - edited

        Problem is also while delta spike already has a vendor neutral api to kick the container through, the api has been done only for testcases.
        So we have to roll our own api until delta spike has added its own bootrstrapping api for webapps.

        Werner Punz added a comment -

        for now only openwebbeans is supported.


          People

          • Assignee:
            Werner Punz
            Reporter:
            Werner Punz
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development