MyFaces CODI
  1. MyFaces CODI
  2. EXTCDI-91

src-assemblies are lost during release procedure and bin-asseblies are renamed

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.1
    • Fix Version/s: 0.9.2
    • Component/s: None
    • Labels:
      None

      Description

      During the release procedure the bin-assemlies which are normally named myfaces-extcdi-assembly-jsfxx-0.9.1-bin.zip are renamed to myfaces-extcdi-assembly-jsfxx-0.9.1.zip (without bin) and the src-assemblies are not uploaded to the staging-repo at all.

      This is most likely a misconfiguration of the assembly or the release plugin. I guess we somehow have to tell the release-plugin which files have to be uploaded to the staging repo and currently we have no such configuration.

        Activity

        Gerhard Petracek made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jakob Korherr made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Jakob Korherr [ jakobkorherr ]
        Fix Version/s 0.9.2 [ 12315919 ]
        Resolution Fixed [ 1 ]
        Jakob Korherr added a comment -

        It turned out to be a configuration problem of the assembly-plugin. The problem is that you can specify a finalName for the assembly output files, but in the further maven-lifecycle (for install and deploy) the .zip and .tar.gz files are referred to as attached artifacts. Thus the specified finalName gets lost and the "new" filename is generated from the artifacts details (artifactId and version).

        The only way to add our "src" and "bin" suffixes is to set appendAssemblyId to true and to change the assembly-ids to "src" and "bin" respectively. I committed the necessary changes including some config-cleanup on the assembly-plugin and now both assemblies are installed correctly.

        NOTE that the final name of the assemblies is now e.g. myfaces-extcdi-assembly-jsf20-0.9.1-bin.zip instead of myfaces-extcdi-jsf20-0.9.1.zip, because maven generates this filename from the project artifactId (as described above).

        Mark Struberg added a comment -

        oki, to clean up the confusion: we already have the ASF source-release.zip (+tar.gz) which is just all the trunk folder tared together and signed. This is what the ASF board considers as an 'Apache distribution'. Those sources are all what counts for them, no binary is needed!

        What Jakob likes to add is another zip which contains the sources.jar maven artifacts in analogy to our bin-release.zip. This is just a goodie!

        Leonardo Uribe added a comment -

        Strange. I downloaded the latest voted artifacts and seems to be ok.

        Jakob Korherr added a comment -

        Could be a bug in the install plugin (got this output on a local test):

        [INFO] Installing /Users/jakobkorherr/IdeaProjects/codi/assembly/jsf20/target/assembly/out/myfaces-extcdi-jsf20-0.9.2-SNAPSHOT-src.tar.gz to /Users/jakobkorherr/.m2/repository/org/apache/myfaces/extensions/cdi/myfaces-extcdi-assembly-jsf20/0.9.2-SNAPSHOT/myfaces-extcdi-assembly-jsf20-0.9.2-SNAPSHOT.tar.gz
        [INFO] Installing /Users/jakobkorherr/IdeaProjects/codi/assembly/jsf20/target/assembly/out/myfaces-extcdi-jsf20-0.9.2-SNAPSHOT-src.zip to /Users/jakobkorherr/.m2/repository/org/apache/myfaces/extensions/cdi/myfaces-extcdi-assembly-jsf20/0.9.2-SNAPSHOT/myfaces-extcdi-assembly-jsf20-0.9.2-SNAPSHOT.zip
        [INFO] Installing /Users/jakobkorherr/IdeaProjects/codi/assembly/jsf20/target/assembly/out/myfaces-extcdi-jsf20-0.9.2-SNAPSHOT-bin.tar.gz to /Users/jakobkorherr/.m2/repository/org/apache/myfaces/extensions/cdi/myfaces-extcdi-assembly-jsf20/0.9.2-SNAPSHOT/myfaces-extcdi-assembly-jsf20-0.9.2-SNAPSHOT.tar.gz
        [INFO] Installing /Users/jakobkorherr/IdeaProjects/codi/assembly/jsf20/target/assembly/out/myfaces-extcdi-jsf20-0.9.2-SNAPSHOT-bin.zip to /Users/jakobkorherr/.m2/repository/org/apache/myfaces/extensions/cdi/myfaces-extcdi-assembly-jsf20/0.9.2-SNAPSHOT/myfaces-extcdi-assembly-jsf20-0.9.2-SNAPSHOT.zip

        xxx-src.zip is installed as xxx.zip and because of the fact that the src-assemblies are installed first, the binary-assemblies overwrite them in the repo.

        Jakob Korherr created issue -

          People

          • Assignee:
            Jakob Korherr
            Reporter:
            Jakob Korherr
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development