Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.3
    • Component/s: None
    • Labels:
      None

      Description

      Deploying a demo app, containing codi to Resin, I am getting a Config excecption there

        Activity

        Matthias Weßendorf added a comment -

        /home/matzew/work/source/JAX2011/Resin/resin-4.0.15/conf/resin.xml:110: org.apache.myfaces.extensions.cdi.jsf.impl.scope.conversation.InstanceProducer.destroyAllConversations is an invalid disposes method because it doesn't match a @Produces method

        108: - Sets max-age for cacheable pages, e.g. static pages.
        109: -->
        110: <resin:if test="$

        {resin.professional}">
        111: <cache-mapping url-pattern="/" max-age="5s"/>
        112: <cache-mapping url-pattern="*.gif" max-age="60s"/>

        at com.caucho.config.xml.XmlConfigContext.error(XmlConfigContext.java:1202)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:461)
        at com.caucho.config.xml.XmlConfigContext.configureNodeAttributes(XmlConfigContext.java:408)
        at com.caucho.config.xml.XmlConfigContext.configureNode(XmlConfigContext.java:363)
        at com.caucho.config.xml.XmlConfigContext.configureChildBean(XmlConfigContext.java:668)
        at com.caucho.config.xml.XmlConfigContext.configureBeanProperties(XmlConfigContext.java:656)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:454)
        at com.caucho.config.xml.XmlConfigContext.configureAttribute(XmlConfigContext.java:323)
        at com.caucho.config.program.NodeBuilderChildProgram.inject(NodeBuilderChildProgram.java:82)
        at com.caucho.config.program.ContainerProgram.inject(ContainerProgram.java:86)
        at com.caucho.config.program.ConfigProgram.configure(ConfigProgram.java:107)
        at com.caucho.env.deploy.EnvironmentDeployController.configureInstance(EnvironmentDeployController.java:452)
        at com.caucho.env.deploy.EnvironmentDeployController.configureInstance(EnvironmentDeployController.java:57)
        at com.caucho.env.deploy.DeployController.startImpl(DeployController.java:626)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.request(StartAutoRedeployAutoStrategy.java:129)
        at com.caucho.env.deploy.DeployController.request(DeployController.java:545)
        at com.caucho.server.webapp.WebAppVersioningController.startImpl(WebAppVersioningController.java:145)
        at com.caucho.server.webapp.WebAppVersioningController.startImpl(WebAppVersioningController.java:45)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:77)
        at com.caucho.env.deploy.DeployController.startOnInit(DeployController.java:493)
        at com.caucho.env.deploy.DeployContainer.start(DeployContainer.java:171)
        at com.caucho.server.webapp.WebAppContainer.start(WebAppContainer.java:713)
        at com.caucho.server.host.Host.start(Host.java:675)
        at com.caucho.env.deploy.DeployController.startImpl(DeployController.java:630)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:77)
        at com.caucho.env.deploy.DeployController.startOnInit(DeployController.java:493)
        at com.caucho.env.deploy.DeployContainer.start(DeployContainer.java:171)
        at com.caucho.server.host.HostContainer.start(HostContainer.java:542)
        at com.caucho.server.cluster.Server.start(Server.java:1211)
        at com.caucho.server.cluster.ServletService.start(ServletService.java:72)
        at com.caucho.env.service.ResinSystem.startServices(ResinSystem.java:508)
        at com.caucho.env.service.ResinSystem.start(ResinSystem.java:476)
        at com.caucho.server.resin.Resin.start(Resin.java:892)
        at com.caucho.server.resin.Resin.initMain(Resin.java:1020)
        at com.caucho.server.resin.Resin.main(Resin.java:1287)
        Caused by: com.caucho.config.ConfigException: org.apache.myfaces.extensions.cdi.jsf.impl.scope.conversation.InstanceProducer.destroyAllConversations is an invalid disposes method because it doesn't match a @Produces method
        at com.caucho.config.inject.ProducesBuilder.introspectProduces(ProducesBuilder.java:117)
        at com.caucho.config.inject.ManagedBeanImpl.introspectProduces(ManagedBeanImpl.java:358)
        at com.caucho.config.inject.InjectManager.addDiscoveredBean(InjectManager.java:3283)
        at com.caucho.config.inject.InjectManager.discoverBeanImpl(InjectManager.java:3228)
        at com.caucho.config.inject.InjectManager.processPendingAnnotatedTypes(InjectManager.java:2968)
        at com.caucho.config.inject.InjectManager.update(InjectManager.java:2949)
        at com.caucho.config.inject.InjectManager.getReferenceFactory(InjectManager.java:1345)
        at com.caucho.config.el.CandiElResolver.getValue(CandiElResolver.java:125)
        at com.caucho.el.StackELResolver.getValue(StackELResolver.java:143)
        at com.caucho.el.IdExpr.getValue(IdExpr.java:110)
        at com.caucho.el.ArrayResolverExpr.getValue(ArrayResolverExpr.java:140)
        at com.caucho.el.PathExpr.getValue(PathExpr.java:142)
        at com.caucho.el.Expr.evalBoolean(Expr.java:232)
        at com.caucho.config.type.BooleanPrimitiveType.valueOf(BooleanPrimitiveType.java:96)
        at com.caucho.config.xml.XmlConfigContext.eval(XmlConfigContext.java:1072)
        at com.caucho.config.xml.XmlConfigContext.configureInlineText(XmlConfigContext.java:544)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:449)
        ... 33 more
        /home/matzew/work/source/JAX2011/Resin/resin-4.0.15/conf/resin.xml:110: org.apache.myfaces.extensions.cdi.jsf.impl.scope.conversation.InstanceProducer.destroyAllConversations is an invalid disposes method because it doesn't match a @Produces method

        108: - Sets max-age for cacheable pages, e.g. static pages.
        109: -->
        110: <resin:if test="${resin.professional}

        ">
        111: <cache-mapping url-pattern="/" max-age="5s"/>
        112: <cache-mapping url-pattern="*.gif" max-age="60s"/>

        at com.caucho.config.xml.XmlConfigContext.error(XmlConfigContext.java:1202)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:461)
        at com.caucho.config.xml.XmlConfigContext.configureNodeAttributes(XmlConfigContext.java:408)
        at com.caucho.config.xml.XmlConfigContext.configureNode(XmlConfigContext.java:363)
        at com.caucho.config.xml.XmlConfigContext.configureChildBean(XmlConfigContext.java:668)
        at com.caucho.config.xml.XmlConfigContext.configureBeanProperties(XmlConfigContext.java:656)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:454)
        at com.caucho.config.xml.XmlConfigContext.configureAttribute(XmlConfigContext.java:323)
        at com.caucho.config.program.NodeBuilderChildProgram.inject(NodeBuilderChildProgram.java:82)
        at com.caucho.config.program.ContainerProgram.inject(ContainerProgram.java:86)
        at com.caucho.config.program.ConfigProgram.configure(ConfigProgram.java:107)
        at com.caucho.env.deploy.EnvironmentDeployController.configureInstance(EnvironmentDeployController.java:452)
        at com.caucho.env.deploy.EnvironmentDeployController.configureInstance(EnvironmentDeployController.java:57)
        at com.caucho.env.deploy.DeployController.startImpl(DeployController.java:626)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.request(StartAutoRedeployAutoStrategy.java:129)
        at com.caucho.env.deploy.DeployController.request(DeployController.java:545)
        at com.caucho.server.webapp.WebAppVersioningController.startImpl(WebAppVersioningController.java:145)
        at com.caucho.server.webapp.WebAppVersioningController.startImpl(WebAppVersioningController.java:45)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:77)
        at com.caucho.env.deploy.DeployController.startOnInit(DeployController.java:493)
        at com.caucho.env.deploy.DeployContainer.start(DeployContainer.java:171)
        at com.caucho.server.webapp.WebAppContainer.start(WebAppContainer.java:713)
        at com.caucho.server.host.Host.start(Host.java:675)
        at com.caucho.env.deploy.DeployController.startImpl(DeployController.java:630)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:77)
        at com.caucho.env.deploy.DeployController.startOnInit(DeployController.java:493)
        at com.caucho.env.deploy.DeployContainer.start(DeployContainer.java:171)
        at com.caucho.server.host.HostContainer.start(HostContainer.java:542)
        at com.caucho.server.cluster.Server.start(Server.java:1211)
        at com.caucho.server.cluster.ServletService.start(ServletService.java:72)
        at com.caucho.env.service.ResinSystem.startServices(ResinSystem.java:508)
        at com.caucho.env.service.ResinSystem.start(ResinSystem.java:476)
        at com.caucho.server.resin.Resin.start(Resin.java:892)
        at com.caucho.server.resin.Resin.initMain(Resin.java:1020)
        at com.caucho.server.resin.Resin.main(Resin.java:1287)
        Caused by: com.caucho.config.ConfigException: org.apache.myfaces.extensions.cdi.jsf.impl.scope.conversation.InstanceProducer.destroyAllConversations is an invalid disposes method because it doesn't match a @Produces method
        at com.caucho.config.inject.ProducesBuilder.introspectProduces(ProducesBuilder.java:117)
        at com.caucho.config.inject.ManagedBeanImpl.introspectProduces(ManagedBeanImpl.java:358)
        at com.caucho.config.inject.InjectManager.addDiscoveredBean(InjectManager.java:3283)
        at com.caucho.config.inject.InjectManager.discoverBeanImpl(InjectManager.java:3228)
        at com.caucho.config.inject.InjectManager.processPendingAnnotatedTypes(InjectManager.java:2968)
        at com.caucho.config.inject.InjectManager.update(InjectManager.java:2949)
        at com.caucho.config.inject.InjectManager.getReferenceFactory(InjectManager.java:1345)
        at com.caucho.config.el.CandiElResolver.getValue(CandiElResolver.java:125)
        at com.caucho.el.StackELResolver.getValue(StackELResolver.java:143)
        at com.caucho.el.IdExpr.getValue(IdExpr.java:110)
        at com.caucho.el.ArrayResolverExpr.getValue(ArrayResolverExpr.java:140)
        at com.caucho.el.PathExpr.getValue(PathExpr.java:142)
        at com.caucho.el.Expr.evalBoolean(Expr.java:232)
        at com.caucho.config.type.BooleanPrimitiveType.valueOf(BooleanPrimitiveType.java:96)
        at com.caucho.config.xml.XmlConfigContext.eval(XmlConfigContext.java:1072)
        at com.caucho.config.xml.XmlConfigContext.configureInlineText(XmlConfigContext.java:544)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:449)
        ... 33 more
        /home/matzew/work/source/JAX2011/Resin/resin-4.0.15/conf/resin.xml:110: org.apache.myfaces.extensions.cdi.jsf.impl.scope.conversation.InstanceProducer.destroyAllConversations is an invalid disposes method because it doesn't match a @Produces method

        108: - Sets max-age for cacheable pages, e.g. static pages.
        109: -->
        110: <resin:if test="$

        {resin.professional}

        ">
        111: <cache-mapping url-pattern="/" max-age="5s"/>
        112: <cache-mapping url-pattern="*.gif" max-age="60s"/>

        at com.caucho.config.xml.XmlConfigContext.error(XmlConfigContext.java:1202)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:461)
        at com.caucho.config.xml.XmlConfigContext.configureNodeAttributes(XmlConfigContext.java:408)
        at com.caucho.config.xml.XmlConfigContext.configureNode(XmlConfigContext.java:363)
        at com.caucho.config.xml.XmlConfigContext.configureChildBean(XmlConfigContext.java:668)
        at com.caucho.config.xml.XmlConfigContext.configureBeanProperties(XmlConfigContext.java:656)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:454)
        at com.caucho.config.xml.XmlConfigContext.configureAttribute(XmlConfigContext.java:323)
        at com.caucho.config.program.NodeBuilderChildProgram.inject(NodeBuilderChildProgram.java:82)
        at com.caucho.config.program.ContainerProgram.inject(ContainerProgram.java:86)
        at com.caucho.config.program.ConfigProgram.configure(ConfigProgram.java:107)
        at com.caucho.env.deploy.EnvironmentDeployController.configureInstance(EnvironmentDeployController.java:452)
        at com.caucho.env.deploy.EnvironmentDeployController.configureInstance(EnvironmentDeployController.java:57)
        at com.caucho.env.deploy.DeployController.startImpl(DeployController.java:626)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.request(StartAutoRedeployAutoStrategy.java:129)
        at com.caucho.env.deploy.DeployController.request(DeployController.java:545)
        at com.caucho.server.webapp.WebAppVersioningController.startImpl(WebAppVersioningController.java:145)
        at com.caucho.server.webapp.WebAppVersioningController.startImpl(WebAppVersioningController.java:45)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:77)
        at com.caucho.env.deploy.DeployController.startOnInit(DeployController.java:493)
        at com.caucho.env.deploy.DeployContainer.start(DeployContainer.java:171)
        at com.caucho.server.webapp.WebAppContainer.start(WebAppContainer.java:713)
        at com.caucho.server.host.Host.start(Host.java:675)
        at com.caucho.env.deploy.DeployController.startImpl(DeployController.java:630)
        at com.caucho.env.deploy.StartAutoRedeployAutoStrategy.startOnInit(StartAutoRedeployAutoStrategy.java:77)
        at com.caucho.env.deploy.DeployController.startOnInit(DeployController.java:493)
        at com.caucho.env.deploy.DeployContainer.start(DeployContainer.java:171)
        at com.caucho.server.host.HostContainer.start(HostContainer.java:542)
        at com.caucho.server.cluster.Server.start(Server.java:1211)
        at com.caucho.server.cluster.ServletService.start(ServletService.java:72)
        at com.caucho.env.service.ResinSystem.startServices(ResinSystem.java:508)
        at com.caucho.env.service.ResinSystem.start(ResinSystem.java:476)
        at com.caucho.server.resin.Resin.start(Resin.java:892)
        at com.caucho.server.resin.Resin.initMain(Resin.java:1020)
        at com.caucho.server.resin.Resin.main(Resin.java:1287)
        Caused by: com.caucho.config.ConfigException: org.apache.myfaces.extensions.cdi.jsf.impl.scope.conversation.InstanceProducer.destroyAllConversations is an invalid disposes method because it doesn't match a @Produces method
        at com.caucho.config.inject.ProducesBuilder.introspectProduces(ProducesBuilder.java:117)
        at com.caucho.config.inject.ManagedBeanImpl.introspectProduces(ManagedBeanImpl.java:358)
        at com.caucho.config.inject.InjectManager.addDiscoveredBean(InjectManager.java:3283)
        at com.caucho.config.inject.InjectManager.discoverBeanImpl(InjectManager.java:3228)
        at com.caucho.config.inject.InjectManager.processPendingAnnotatedTypes(InjectManager.java:2968)
        at com.caucho.config.inject.InjectManager.update(InjectManager.java:2949)
        at com.caucho.config.inject.InjectManager.getReferenceFactory(InjectManager.java:1345)
        at com.caucho.config.el.CandiElResolver.getValue(CandiElResolver.java:125)
        at com.caucho.el.StackELResolver.getValue(StackELResolver.java:143)
        at com.caucho.el.IdExpr.getValue(IdExpr.java:110)
        at com.caucho.el.ArrayResolverExpr.getValue(ArrayResolverExpr.java:140)
        at com.caucho.el.PathExpr.getValue(PathExpr.java:142)
        at com.caucho.el.Expr.evalBoolean(Expr.java:232)
        at com.caucho.config.type.BooleanPrimitiveType.valueOf(BooleanPrimitiveType.java:96)
        at com.caucho.config.xml.XmlConfigContext.eval(XmlConfigContext.java:1072)
        at com.caucho.config.xml.XmlConfigContext.configureInlineText(XmlConfigContext.java:544)
        at com.caucho.config.xml.XmlConfigContext.configureChildNode(XmlConfigContext.java:449)
        ... 33 more

        Matthias Weßendorf added a comment -

        this issue is not present with 0.9.3

        Mark Struberg added a comment -

        yes, the whole method got removed.

        Nonetheless, the issue is a bug in CanDI, because this disposal method is programmed in exaclty the way described in the spec paragraph
        3.3.6. Declaring a disposer method

        @Produces @ConversationScoped @UserDatabase
        public EntityManager create(EntityManagerFactory emf) { ...

        public void close(@Disposes @UserDatabase EntityManager em) {

        please note that the disposal method doesn't need to mention the scope. (And btw, it also doesn't need the qualifier afaik).


          People

          • Assignee:
            Unassigned
            Reporter:
            Matthias Weßendorf
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development