Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.3, 1.4
    • Component/s: Server
    • Labels:
      None
    • Environment:
      Win7 chrome, firefox

      Description

      Create a pool. I'm in it as admin. Create another user in another browser. Have that new user add some messages. Then, original user adds new user to pool. Nothing happens; no user shows up. Refresh page. Still no user.

        Activity

        Ethan Jewett added a comment -

        Unfortunately I either don't understand or can't recreate this issue on Chrome in MacOS X either locally or on http://esmecloudserverapache.dickhirsch.staxapps.net. I do the following:

        1. Create a new pool (in Chrome)
        2. In a different browser (Safari) I create a new user (testuser2)
        3. (Back in Chrome, for the duration) reload the My Pools page
        4. Choose the new pool
        5. Click the edit button
        6. In the user field, type "test"
        7. The "testuser2" value shows up in the selection list, and I select it
        8. Add the user to the pool with Read capability
        9. A couple of seconds later the list of users in the pool is automatically updated with "testuser2" and a "Read" privilege.

        Are you doing step 3, reloading? This is necessary to get the name of the new user. The list of users is cached, I believe in the Snippet after the first attempt to add a user to a pool.

        Jack Park added a comment -

        Step 3 appears critical. The issue is now resolved.
        I suspect that Step 3 is based on the way Lift binds values; refreshing is required to gain a different binding.

        Jack Park added a comment -

        A missing step in user gestures, not a bug, is in play on this one.


          People

          • Assignee:
            Ethan Jewett
            Reporter:
            Jack Park
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development