Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.3
    • Component/s: Server
    • Labels:
      None

      Description

      Right now when user needs to add someone to it's own pool he types username in text input field. This value is then submitted to server and is written to the 'username' var. After that 'addPoolUser' local function validates submitted value and searches corresponding User entity in DB.

      I suggest to replace this text input field with Lift's AutoComplete widget, so when user begins to type text, SQL query like "select nickname from users where nickname like 'typed_text%'" is executed via ajax call and list of matched nicknames is displayed. User subsequently selects nickname from list and it is then saved into the same variable 'username'.

        Activity

        Hudson added a comment -

        Integrated in ESME #575 (See https://builds.apache.org/hudson/job/ESME/575/)
        ESME-345: Fixed widget malfunction with Chrome

        Dick Hirsch added a comment -

        Tested with IE, FireFox and Chrome.

        Looks great.

        Closing

        Vladimir Ivanov added a comment -

        It's strange but it was 'tipelement' CSS class which had been the cause of widget malfunction with Chrome. Could you please check autocompleter again?

        Hudson added a comment -

        Integrated in ESME #574 (See https://builds.apache.org/hudson/job/ESME/574/)
        ESME-345: Add autocompleter for add/edit pool member operation

        Vladimir Ivanov added a comment -

        Yes, it doesn't work in Chrome (11.0.696.50 beta, Windows platform) for me either. It works in Firefox 4 and IE7. I'll try to figure things out this night. Should I revert this change in SVN?

        Vladimir Ivanov added a comment -

        Hmm. I tested it in Firefox. I'll check it in Chrome in ten minutes.

        Dick Hirsch added a comment -

        I tried with Chrome locally and it didn't work. Which browser are you using?

        Vladimir Ivanov added a comment - - edited

        I've added AutoComplete widget, but unfortunately it's not perfect: https://www.assembla.com/spaces/liftweb/tickets/892-autocomplete%28%29-should-have-option-to-allow-user-to-enter-their-own-value

        David Pollak made a post in Lift Google Group that he is going to improve this widget and align it to JQuery examples: http://view.jquery.com/trunk/plugins/autocomplete/demo/ , so problems above might be fixed in near future: https://groups.google.com/d/topic/liftweb/zh4AO_RQNDw/discussion

        In case you consider these problems as important ones, I'll revert this change.


          People

          • Assignee:
            Vladimir Ivanov
            Reporter:
            Vladimir Ivanov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development