Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Component/s: Server
    • Labels:
      None

      Description

      After discussion on dev mailing list, this will be a complete rewrite of the comet timeline to use incremental updates. There are several bugs that can be addressed at the same time.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          108d 15h 49m 1 Ethan Jewett 15/May/11 10:52
          Resolved Resolved Closed Closed
          59d 4h 10m 1 Dick Hirsch 13/Jul/11 15:03
          Dick Hirsch made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Hudson added a comment -

          Integrated in ESME #593 (See https://builds.apache.org/hudson/job/ESME/593/)
          ESME-328 ESME-308 Re-introduce prettification of message times and update message times in the timeline every 30 seconds.

          Ethan Jewett made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Ethan Jewett made changes -
          Link This issue is blocked by ESME-282 [ ESME-282 ]
          Hudson added a comment -

          Integrated in ESME #563 (See https://hudson.apache.org/hudson/job/ESME/563/)
          ESME-328 Convert search to use comet timeline, make search box a little cleaner, fix error in stream timline caused by leftover code, clean up code that is now unused in display...js files and delete message_core.html

          Hudson added a comment -

          Integrated in ESME #560 (See https://hudson.apache.org/hudson/job/ESME/560/)
          ESME-328 Switch SinglePublicTimeline over to the new rendering method. This is the last timeline on the old method.

          Hudson added a comment -

          Integrated in ESME #557 (See https://hudson.apache.org/hudson/job/ESME/557/)
          ESME-328 ESME-268 Comet timeline rewrite merge. There are still a couple todos noted in the source of Timeline.scala, but everything should be working.

          Ethan Jewett made changes -
          Assignee Ethan Jewett [ esjewett ]
          Dick Hirsch made changes -
          Link This issue is blocked by ESME-282 [ ESME-282 ]
          Dick Hirsch made changes -
          Fix Version/s 1.3 [ 12316109 ]
          Affects Version/s 1.2 [ 12315284 ]
          Affects Version/s Backlog [ 12314285 ]
          Dick Hirsch added a comment -

          Changed this 1.3

          Eric J. Christeson made changes -
          Link This issue is blocked by ESME-315 [ ESME-315 ]
          Eric J. Christeson made changes -
          Link This issue is blocked by ESME-314 [ ESME-314 ]
          Eric J. Christeson made changes -
          Link This issue is blocked by ESME-308 [ ESME-308 ]
          Eric J. Christeson made changes -
          Link This issue is blocked by ESME-295 [ ESME-295 ]
          Eric J. Christeson added a comment -

          These issues should be able to be addressed with a comet timeline rewrite.

          Eric J. Christeson made changes -
          Field Original Value New Value
          Link This issue is blocked by ESME-268 [ ESME-268 ]
          Eric J. Christeson created issue -

            People

            • Assignee:
              Ethan Jewett
              Reporter:
              Eric J. Christeson
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development