Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.1
    • Labels:
      None

      Description

      Copied more or less directly from the one just checked in for pool; appropriate substitution made for project info, contributors, dependencies, and test cases.

      One problem: dumbster-SNAPSHOT is not in any Maven 2 repository that I know of and must be manually installed. Everything else seems to work fine.

      Attaching file shortly...

      1. pomv3.xml
        9 kB
        Bindul Bhowmik
      2. pom.patch
        9 kB
        Bindul Bhowmik
      3. pomv2.xml
        9 kB
        Ben Speakmon
      4. pom.xml
        8 kB
        Ben Speakmon

        Activity

        Henri Yandell added a comment -

        The dumbster SNAPSHOT is in the m1 snapshot repository at apache. See the project.properties for the url.

        It needs to be added as a legacy repository in the pom.

        Henri Yandell added a comment -

        Also, email should probably move to using Jon Stevens' Wiser project as Dumbster seems dead.

        Ben Speakmon added a comment -

        Added the m1 snapshot repository (it wasn't in commons.parent or apache.parent). It gets dumbster properly now.

        As far as wiser is concerned, I agree that depending on a dead project's snapshot is bad. (I'm familiar with wiser, and it will work for testing.) I'll open another issue for that.

        Bindul Bhowmik added a comment -

        Shouldn't the groupId for the component be org.apache.commons?

        Ben Speakmon added a comment -

        I would think so, but I preserved the usage from the pool pom.xml. I don't know enough about how the commons developers want them done, so I figured leaving it alone was safest. I'll defer to them on this.

        Bindul Bhowmik added a comment -

        The junit tests fail with the attached poms, basically the test resource directory was not set. I am attaching the patch (and the pom) with the required modifications. This POM still has dumbster as a dependency.

        Bindul Bhowmik added a comment -

        POM patch

        Bindul Bhowmik added a comment -

        POM version 3

        Ben Speakmon added a comment -

        The tests passed for me without setting any testResources – just specifying that test cases lived in src/test was enough. I'm curious why they were failing.

        I did get a failure when I first tried the pom, but after trying it again a bit later it worked fine. I figured it was cosmic rays, but now I wonder if there's a maven subtlety I'm missing. I'm not convinced that the testResources addition is necessary here.

        Bindul Bhowmik added a comment -

        Here is my understanding and resolution of the problem:

        One of the referenced files in the test cases - EmailConfiguration.java is reading a file from the class loader -

        <pre>
        public static final String TEST_URL = EmailConfiguration.class
        .getResource("/images/asf_logo_wide.gif")
        .toExternalForm();
        </pre>

        The file (asf_logo_wide.gif) resides in the src/test/images directory. Without specifying the testResources, maven is not copying the file to the target/test-classes directory, and hence all tests (except DefaultAuthenticatorTest - which does not cause that class to be loaded) are failing.

        The only way I could fix the issue is to add testResources.

        For the curious, my system configuration is Windows XP Professional. I have run the tests both under Sun Java 1.4.2_11 and 1.5.0_11 using Maven 2.0.2 (a bit behind the curve here).

        Ben Speakmon added a comment -

        Ohhh, I get it. You're right. By all means, put it in there.

        Bindul Bhowmik added a comment -

        I was trying to test the site generation with maven 2 and the new POM and maven is not generating the site from the xdocs. I think Maven expects the site documents to be present at src/site and it also requires a site.xml (http://maven.apache.org/guides/mini/guide-site.html). I am not a maven expert, so could someone please help out? Or point me to the right direction for building the site please?

        Henri Yandell added a comment -

        The pom.xml's aren't used for site generation yet. As far as I know, it's a pain in the arse to support sites from both so I've been making the pom.xmls for compiling/tests so far and figured the move to an m2 site would involve more changing.

        Dennis Lundberg added a comment -

        You need to bump the version of commons-parent from 1 to 2-SNAPSHOT. That will make the site work.

        Henri Yandell added a comment -

        svn ci -m "Adding Maven2 pom from Ben Speakmon EMAIL-63" pom.xml
        Adding pom.xml
        Transmitting file data .
        Committed revision 509843.


          People

          • Assignee:
            Unassigned
            Reporter:
            Ben Speakmon
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development