DeltaCloud
  1. DeltaCloud
  2. DTACLOUD-78

Instance name provided while starting an image is not reflected in Amazon EC2 instance description, displays as "Unnamed (ami-xxx)"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: Client (Ruby)
    • Labels:
      None
    • Environment:
      Deltacloud API 0.4.0

      Description

      Instance name provided while starting an image is not reflected in Amazon EC2 instance description, displays as "Unnamed (ami-xxx)"

      Reproduction Steps:
      ===============
      1. From Images, select an AMI and provide the "Instance name" and all the necessary parameters in the Launch new instance page and click on "Create Instance" button.
      2. Once the Image starts successfully, login to amazon EC2, select the previously started image and check for the EC2 Instance Description for the field "AMI"

      Expected Result:
      =============
      Should display the AMI as "<provided instance name> (ami - xxx)"

      Actual Result:
      ==========
      Displays the AMI as "Unnamed (ami-xxx)"

        Activity

        Ramesh A added a comment -

        Closing this issue as per the previous comment

        Ramesh A added a comment -

        This solution seems to make sense if EC2 is no longer supporting this feature. Hence closing this issue

        Michal Fojtik added a comment -

        The 'name' field is not longer shown in new instance screen in UI, because EC2 doesn't have 'user_name' feature.

        Later we should consider managing tags or using user_data for the instance name.
        Let me know if this solution works for you.


          People

          • Assignee:
            Michal Fojtik
            Reporter:
            Ramesh A
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development