DeltaCloud
  1. DeltaCloud
  2. DTACLOUD-78

Instance name provided while starting an image is not reflected in Amazon EC2 instance description, displays as "Unnamed (ami-xxx)"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: Client (Ruby)
    • Labels:
      None
    • Environment:
      Deltacloud API 0.4.0

      Description

      Instance name provided while starting an image is not reflected in Amazon EC2 instance description, displays as "Unnamed (ami-xxx)"

      Reproduction Steps:
      ===============
      1. From Images, select an AMI and provide the "Instance name" and all the necessary parameters in the Launch new instance page and click on "Create Instance" button.
      2. Once the Image starts successfully, login to amazon EC2, select the previously started image and check for the EC2 Instance Description for the field "AMI"

      Expected Result:
      =============
      Should display the AMI as "<provided instance name> (ami - xxx)"

      Actual Result:
      ==========
      Displays the AMI as "Unnamed (ami-xxx)"

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Michal Fojtik
            Reporter:
            Ramesh A
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development