DeltaCloud
  1. DeltaCloud
  2. DTACLOUD-132

deltacloudd & deltacloudc command not found

    Details

    • Type: Question Question
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu

      Description

      Hai,

      We are trying out deltacloud in ubuntu. we have installed the required dependencies. Also we have installed deltacloud-core and deltacloud-client using gem install. We are able to get the response for gem list deltacloud-core and gem list deltacloud-client. But we are not able to work with the deltacloudd and deltacloudc command line tools.

      When we give ' which deltacloudd ' , it simply skips to the next command line without displaying any location for the gem and the start script. Please suggest us to get those commands and to run the deltacloud server.

      Raja

        Activity

        Marios Andreou made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Not A Problem [ 8 ]
        Marios Andreou added a comment -

        Hi Raja,

        ok - now we're getting to the bottom of this. The problem is that, although it seems installation was successful, your system can't find the detacloudd executable because the directory /var/lib/gems/1.8/bin is not in your $PATH. You can resolve this either by using the full path to deltacloudd when running the server:

        /var/lib/gems/1.8/bin/deltacloudd -i ec2
        (for example to start server with the ec2 driver)

        OR

        you can place that directory in your path: "export PATH=$PATH:/var/lib/gems/1.8/bin"

        (and you may want to place this in your $HOME/.bashrc file so it is exported every time you open a terminal shell). Please let me know if that works for you so I can close this issue,

        marios

        Rajaguganeswaran K added a comment -

        Yes, We have the deltacloud-core-0.4.1 in /var/ lib/gems/1.8/gems, the deltacloudd executable is palced in /var/lib/gems/1.8/bin/

        And as said in the original document required dependencies were installed and have done deltacloud-core and deltalcoud-client using

        sudo gem install deltalcoud-core.

        Raja

        Marios Andreou added a comment -

        OK: so it looks like the installation was not successful.

        In your original comment, you said that you "installed the required dependencies. Also we have installed deltacloud-core and deltacloud-client using gem install". Does this mean you did a 'sudo gem install deltacloud-core' ?

        First check whether deltacloud-core gem was actually installed. On my system gems are in /usr/lib/ruby/gems/1.8 . It may be different for you. You can discover the installation directory with 'gem environment' - which gives details like ruby version and installation directory. Check if deltacloud-core-<version> exists in that the gem installation directory.

        The 'gem environment' command will also tell you where gem executables are installed. For example "EXECUTABLE DIRECTORY: /usr/bin" - which means that the deltacloudd executable will be placed here.

        marios

        Rajaguganeswaran K added a comment -

        Hai,

        When ever we use deltacloudd or deltacloudc command as you said,

        deltacloudd -i mock or anything it shows deltacloudd: command not found.

        What could be the reason?

        Raja

        Marios Andreou added a comment -

        Hi Raja,

        wow - its strange that you get nothing from

        which deltacloudd

        Normally you'd get either the location of the executable (e.g. /usr/bin/deltacloudd) or a message saying it wasn't found (e.g. /usr/bin/which: no deltacloudd in $PATH).

        What happens when you just try to run deltacloudd? So:

        deltacloudd -i mock

        for example?

        marios

        Rajaguganeswaran K created issue -

          People

          • Assignee:
            David Lutterkort
            Reporter:
            Rajaguganeswaran K
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development