Apache Drill
  1. Apache Drill
  2. DRILL-782

ArrayIndexOutOfBoundsException encountered in a sequence of query executions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.4.0
    • Component/s: Execution - Flow
    • Labels:
      None

      Description

      Datasources: TPCH (10MB), three-way split parquet files
      git.commit.id.abbrev=70fab8c
      git.commit.id=70fab8c968a6dc05471aa1f32009cd15945d4f3d

      Follow the steps in exactly this order:
      1. Restart drillbit

      2. 0: jdbc:drill:schema=dfs.TpcHMulti> select c_custkey from customer1 order by c_custkey;
      ------------

      c_custkey

      ------------

      1
      2
      3
      4
      ...

      ------------

      1500

      ------------
      1,500 rows selected (2.781 seconds)

      3. Repeat the above query:

      0: jdbc:drill:schema=dfs.TpcHMulti> select c_custkey from customer1 order by c_custkey;
      Query failed: org.apache.drill.exec.rpc.RpcException: Remote failure while running query.[error_id: "604a3e93-0eaf-4697-8367-d1d193624413"
      endpoint

      { address: "perfnode104.perf.lab" user_port: 31010 control_port: 31011 data_port: 31012 }


      error_type: 0
      message: "Failure while running fragment. < IndexOutOfBoundsException:[ index: 640, length: 8 (expected: range(0, 640)) ]"
      ]
      Error: exception while executing query (state=,code=0)

      4. Now, add limit:

      0: jdbc:drill:schema=dfs.TpcHMulti> select c_custkey from customer1 order by c_custkey limit 5;
      ------------

      c_custkey

      ------------

      1
      2
      3
      4
      5

      ------------
      5 rows selected (0.465 seconds)

        Activity

        Zhiyong Liu added a comment -

        It is indeed fixed - not reproducible on the following build:

        git.commit.id.abbrev=fb2091a
        git.commit.id=fb2091ad74bc677b309e5d32d375729dd5bf45bc

        I am marking it resolved.

        Steven Phillips added a comment -

        It looks like this issue is no longer present. I can reproduce it when I check out the version this was reported on, but in the latest build, I do not see it anymore.

        Can you retest this on latest build?


          People

          • Assignee:
            Zhiyong Liu
            Reporter:
            Zhiyong Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development