Apache Drill
  1. Apache Drill
  2. DRILL-622

Failure while running fragment. < IndexOutOfBoundsException: [index: 76080, length: 556 (expected: range(0, 76250)) ]

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 0.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      centos 6.2 VM

      Description

      getting this error while running query on some dataset using tsv engine:
      >SELECT columns[6] from `/user/root/cust-header.tsv` limit 2;
      Query failed: org.apache.drill.exec.rpc.RpcException: Remote failure while running query.[error_id: "dedf1821-eb00-47dc-b794-0266e84606a9"
      endpoint

      { address: "mfs101.qa.lab" user_port: 31010 control_port: 31011 data_port: 31012 }

      error_type: 0
      message: "Failure while running fragment. < IndexOutOfBoundsException:[ index: 76080, length: 556 (expected: range(0, 76250)) ]"
      ]
      Error: exception while executing query (state=,code=0)

      But if I run SELECT * FROM the same table, it doesn't throw that error :

      > SELECT * from `/user/root/cust-header.tsv` limit 2;
      ------------

      columns

      ------------

      [c0, c1, c2-pattern_id, c3, c4, c5, c6, c7, c8, c9, c10, c11, c12, c13, c14-title, c15, c16, c17, c18, c19, c0, c21, c22, c23, c24-uid, c25-recorded, c26, c27, c28, c29, c30-country, c31, c32]
      [T, 401932827, 1000213, 27, 644297049, 55, /r?c2=1000004&d.c=txt&d.o=nbculimdivisionprod&d.x=195385085&d.t=media&d.m=Afternoon%20Weather%20Video%3A%20Monday%2C%20September%2024%2C%202012&cs_domain_id=6433039443649550087&cs_metro_code=803&cs_ec=US&cs_boc=1346867748, 0, 1000004, , nbculimdivisionprod, , , , Afternoon Weather Video: Monday, September 24, 2012, , OMTR, , , , , , , 0, 937021026, 2816d925-6902-2014-8017-113468677480, 2012-09-25 00:00:27.132, 20120906.02, 60f2761d0e6192a88305054eb06877cb, 1, -8, US, 90189, 1001]

      ------------
      2 rows selected (0.112 seconds)

      Debugging info from Lilith:

      java.lang.IndexOutOfBoundsException: index: 76080, length: 556 (expected: range(0, 76250))
      at io.netty.buffer.AbstractByteBuf.checkIndex(AbstractByteBuf.java:1130) ~[netty-buffer-4.0.7.Final.jar:na]
      at io.netty.buffer.PooledUnsafeDirectByteBufL.setBytes(PooledUnsafeDirectByteBufL.java:216) ~[drill-buffers-1.0.0-m2-incubating-SNAPSHOT.jar:na]
      at org.apache.drill.exec.memory.AccountingByteBuf.setBytes(AccountingByteBuf.java:415) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at org.apache.drill.exec.vector.VarCharVector$Mutator.set(VarCharVector.java:412) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at org.apache.drill.exec.test.generated.ProjectorGen116.doEval(ProjectorTemplate.java:39) ~[na:na]
      at org.apache.drill.exec.test.generated.ProjectorGen116.projectRecords(ProjectorTemplate.java:64) ~[na:na]
      at org.apache.drill.exec.physical.impl.project.ProjectRecordBatch.doWork(ProjectRecordBatch.java:78) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at org.apache.drill.exec.record.AbstractSingleRecordBatch.next(AbstractSingleRecordBatch.java:62) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at org.apache.drill.exec.record.AbstractSingleRecordBatch.next(AbstractSingleRecordBatch.java:42) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at org.apache.drill.exec.physical.impl.limit.LimitRecordBatch.next(LimitRecordBatch.java:87) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at org.apache.drill.exec.physical.impl.ScreenCreator$ScreenRoot.next(ScreenCreator.java:85) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at org.apache.drill.exec.work.fragment.FragmentExecutor.run(FragmentExecutor.java:83) ~[drill-java-exec-1.0.0-m2-incubating-SNAPSHOT-rebuffed.jar:1.0.0-m2-incubating-SNAPSHOT]
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.0_45]
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.0_45]
      at java.lang.Thread.run(Thread.java:744) [na:1.7.0_45]

        Activity

        Vivian Summers created issue -
        Jake Farrell made changes -
        Field Original Value New Value
        Workflow no-reopen-closed, patch-avail [ 12859437 ] no-reopen-closed, patch-avail, testing [ 12860167 ]
        Vivian Summers added a comment -

        It's working fine with original datafile without added header, mark it resolved:
        0: jdbc:drill:schema=dfs> SELECT columns[6] from `/user/root/cust-d1.tsv` limit 2;
        ------------

        EXPR$0

        ------------

        /r?c2=1000004&d.c=txt&d.o=nbculimdivisionprod&d.x=195385085&d.t=media&d.m=Afternoon%20Weather%20Video%3A%20Monday%2C%20September%2024%2C%202012&c
        /r2?c2=1000004&d.c=txt&d.o=nbculimdivisionprod&d.x=214342552&d.t=media&d.u=Unknown&d.m=Applied%20Electronics%20At%20Granby%20High%20School&&cs_do
        Vivian Summers made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Jacques Nadeau made changes -
        Fix Version/s 0.4.0 [ 12324963 ]
        Tony Stevenson made changes -
        Workflow no-reopen-closed, patch-avail, testing [ 12860167 ] Drill workflow [ 12933817 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        26d 5h 43m 1 Vivian Summers 29/May/14 02:03

          People

          • Assignee:
            Unassigned
            Reporter:
            Vivian Summers
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development