Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.11.0
    • Fix Version/s: 1.12.0
    • Component/s: None
    • Labels:

      Description

      Currently, Drill uses Jackson 2.7.1. The goal of this Jira is to update Jackson version to 2.7.8.

      All Jackson versions 2.7.x before 2.7.8 have CVE-2016-7051 vulnerability.
      The problem was with the jackson-dataformat-xml module (issue-211).
      Drill does not use this module yet, but we want to update the version for the case when we start to use this module.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vvysotskyi Volodymyr Vysotskyi
                Reporter:
                vvysotskyi Volodymyr Vysotskyi
                Reviewer:
                Paul Rogers
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: