Uploaded image for project: 'Apache Drill'
  1. Apache Drill
  2. DRILL-462

Periodic connection failure with Drillbit

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: Execution - RPC
    • Labels:
      None

      Description

      Running into this quite often.

      • Start Drill bit
      • Connect to Drill bit via SQL line and perform few queries
      • Stay idle for some time with no activity, SQLLine disconnects to Drill bit
      • Connect again, gives 'No DrillbitEndpoint can be found'
      • Do JPS, drill bit is still running

      The workaround is to restart Drill service (which is running) and connect from SQLine.

        Activity

        jnadeau Jacques Nadeau added a comment -

        can you confirm that the java client reconnects to zk and finds a drillbit if it loses zk connection.

        cwestin Chris Westin added a comment -

        This is pretty old, and a lot of things have changed in this area; please verify that this is still happening.

        sudheeshkatkam Sudheesh Katkam added a comment -

        Not a problem any more. I left sqlline idle for around 2 hours and it did not disconnect.

        prasanna.p@trinitymobility.com prasanna.p@trinitymobility.com added a comment -

        Currently i am using apache drill 1.9.0. Now I am also facing same issue,my
        java application is using drill for query purpose.But periodically
        disconnects with drillbit service after few queries executions. If we use
        jps it is showing drillbit service is running.I am not find the cause,am i
        missing anything in the flow.I am getting logs as,

        ERROR 2017-02-28 10:12 (http-nio-8098-exec-5)
        org.trinity.social.dao.SocialDataDaoImpl StatementCallback; uncategorized
        SQLException for SQL [SELECT source, sentiment, COUNT AS data_count FROM
        dfs.tmp.social_data_nlp WHERE created_time > DATE_SUB(CURRENT_DATE, 1) AND
        keyword_search = true AND ( searched_keyword = 'fire' OR searched_keyword =
        'acciden' OR user_name = 'aajtak') GROUP BY source, sentiment]; SQL state
        [null]; error code [0]; SYSTEM ERROR: RetriesExhaustedException: Can't get
        the locations

        [Error Id: 9f6ccd37-ee0f-47b4-9a6b-4eeb4456d542 on
        trinitybdClusterM02.trinitymobility.local:31010]; nested exception is
        java.sql.SQLException: SYSTEM ERROR: RetriesExhaustedException: Can't get
        the locations

        [Error Id: 9f6ccd37-ee0f-47b4-9a6b-4eeb4456d542 on
        trinitybdClusterM02.trinitymobility.local:31010]

        org.springframework.jdbc.UncategorizedSQLException: StatementCallback;
        uncategorized SQLException for SQL [SELECT source, sentiment, COUNT AS
        data_count FROM dfs.tmp.social_data_nlp WHERE created_time >
        DATE_SUB(CURRENT_DATE, 1) AND keyword_search = true AND ( searched_keyword =
        'fire' OR searched_keyword = 'acciden' OR user_name = 'aajtak') GROUP BY
        source, sentiment]; SQL state [null]; error code [0]; SYSTEM ERROR:
        RetriesExhaustedException: Can't get the locations

        [Error Id: 9f6ccd37-ee0f-47b4-9a6b-4eeb4456d542 on
        trinitybdClusterM02.trinitymobility.local:31010]; nested exception is
        java.sql.SQLException: SYSTEM ERROR: RetriesExhaustedException: Can't get
        the locations

        [Error Id: 9f6ccd37-ee0f-47b4-9a6b-4eeb4456d542 on
        trinitybdClusterM02.trinitymobility.local:31010]

        at
        org.springframework.jdbc.support.AbstractFallbackSQLExceptionTranslator.tran
        slate(AbstractFallbackSQLExceptionTranslator.java:84)
        ~[spring-jdbc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.jdbc.support.AbstractFallbackSQLExceptionTranslator.tran
        slate(AbstractFallbackSQLExceptionTranslator.java:81)
        ~[spring-jdbc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.jdbc.support.AbstractFallbackSQLExceptionTranslator.tran
        slate(AbstractFallbackSQLExceptionTranslator.java:81)
        ~[spring-jdbc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.jdbc.core.JdbcTemplate.execute(JdbcTemplate.java:419)
        ~[spring-jdbc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.jdbc.core.JdbcTemplate.query(JdbcTemplate.java:474)
        ~[spring-jdbc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.jdbc.core.JdbcTemplate.query(JdbcTemplate.java:484)
        ~[spring-jdbc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.jdbc.core.JdbcTemplate.queryForList(JdbcTemplate.java:51
        0) ~[spring-jdbc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.trinity.social.dao.SocialDataDaoImpl.getAllDataByKeywordCount(SocialData
        DaoImpl.java:98) [classes/:?]

        at
        org.trinity.social.service.SpatialDataFilterServiceImpl.getDataByKeywords(Sp
        atialDataFilterServiceImpl.java:48) [classes/:?]

        at
        org.trinity.social.controller.SocialDataController.getKeywordData(SocialData
        Controller.java:26) [classes/:?]

        at sun.reflect.GeneratedMethodAccessor106.invoke(Unknown Source)
        ~[?:?]

        at
        sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
        .java:43) ~[?:1.8.0_66]

        at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_66]

        at
        org.springframework.web.method.support.InvocableHandlerMethod.doInvoke(Invoc
        ableHandlerMethod.java:220) [spring-web-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.method.support.InvocableHandlerMethod.invokeForReque
        st(InvocableHandlerMethod.java:134)
        [spring-web-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.mvc.method.annotation.ServletInvocableHandle
        rMethod.invokeAndHandle(ServletInvocableHandlerMethod.java:116)
        [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerA
        dapter.invokeHandlerMethod(RequestMappingHandlerAdapter.java:827)
        [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerA
        dapter.handleInternal(RequestMappingHandlerAdapter.java:738)
        [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.mvc.method.AbstractHandlerMethodAdapter.hand
        le(AbstractHandlerMethodAdapter.java:85)
        [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServl
        et.java:963) [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServle
        t.java:897) [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkSer
        vlet.java:970) [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.jav
        a:872) [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:648)
        [servlet-api.jar:?]

        at
        org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.ja
        va:846) [spring-webmvc-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
        [servlet-api.jar:?]

        at
        org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
        FilterChain.java:292) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
        ain.java:207) [catalina.jar:8.0.39]

        at
        org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
        [tomcat-websocket.jar:8.0.39]

        at
        org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
        FilterChain.java:240) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
        ain.java:207) [catalina.jar:8.0.39]

        at
        org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(Char
        acterEncodingFilter.java:197) [spring-web-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestF
        ilter.java:107) [spring-web-4.3.5.RELEASE.jar:4.3.5.RELEASE]

        at
        org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
        FilterChain.java:240) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
        ain.java:207) [catalina.jar:8.0.39]

        at
        org.apache.logging.log4j.web.Log4jServletFilter.doFilter(Log4jServletFilter.
        java:71) [log4j-web-2.5.jar:2.5]

        at
        org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
        FilterChain.java:240) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
        ain.java:207) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja
        va:212) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja
        va:106) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:141
        ) [catalina.jar:8.0.39]

        at
        org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:79)
        [catalina.jar:8.0.39]

        at
        org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogVa
        lve.java:616) [catalina.jar:8.0.39]

        at
        org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
        :88) [catalina.jar:8.0.39]

        at
        org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:509)
        [catalina.jar:8.0.39]

        at
        org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Proce
        ssor.java:1104) [tomcat-coyote.jar:8.0.39]

        at
        org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(Abstrac
        tProtocol.java:684) [tomcat-coyote.jar:8.0.39]

        at
        org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.jav
        a:1520) [tomcat-coyote.jar:8.0.39]

        at
        org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:
        1476) [tomcat-coyote.jar:8.0.39]

        at
        java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:11
        42) [?:1.8.0_66]

        at
        java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:6
        17) [?:1.8.0_66]

        at
        org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.ja
        va:61) [tomcat-util.jar:8.0.39]

        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66]

        Caused by: java.sql.SQLException: SYSTEM ERROR: RetriesExhaustedException:
        Can't get the locations

        please provide any suggestions.

        Thanks & Regards,

        Prasanna.P


          People

          • Assignee:
            sudheeshkatkam Sudheesh Katkam
            Reporter:
            Neeraja Neeraja
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Development