Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.5.0
    • Component/s: None
    • Labels:
      None

      Description

      For a table in HBase or MapR-DB with metadata created in Hive so that it can be accessed through beeline or Hue. From Drill query fail with
      org.apache.drill.common.exceptions.UserRemoteException: SYSTEM ERROR: NullPointerException [Error Id: 1cfd2a36-bc73-4a36-83ee-ac317b8e6cdb]

        Activity

        ckran ckran added a comment -

        Using the sample MapR-DB table 'customers' that is distributed with the MapR Sandbox create metadata in Hive with:

        create external table customers ( key varchar(5),
        address_state varchar(4),
        loyalty_agg_rev varchar(8),
        loyalty_mebership varchar(8),
        personal_age varchar(8),
        personal_gender varchar(8),
        personal_name varchar(32) )
        STORED BY 'org.apache.hadoop.hive.hbase.HBaseStorageHandler'
        WITH SERDEPROPERTIES ('hbase.columns.mapping' =
        ':key,address:state,loyalty:agg_rev,loyalty:membership,personal:age,personal:gender,personal:name')
        TBLPROPERTIES ('hbase.table.name' = 'CUSTOMERS') ;

        githubbot ASF GitHub Bot added a comment -

        GitHub user vkorukanti opened a pull request:

        https://github.com/apache/drill/pull/215

        DRILL-3739: Fix issues in reading Hive tables with StorageHandler configuration (eg. Hive-HBase tables)

        Issue is for Hive tables with custom storage handlers (such as HBase backed Hive tables), InputFormat class is not stored in StorageDescriptor in Hive metastore. Instead it is retrieved from the StorageHandler.getInputFormatClass. This is new change made in Hive after Hive 0.13.

        Fix is: if we can't find the InputFormat class in metastore, create StorageHandler instance of the table and get the InputFormat from the instance. If the StorageHandler doesn't exists throw an exception. Behavior here is similar to Hive.

        In order for Hive-HBase tables to work following config properties need to be added to Hive storage plugin config section:
        "hbase.zookeeper.quorum": "zkhost1,zkhost2,zkhost3",
        "hbase.zookeeper.property.clientPort": "2181" // ZooKeeper port

        These properties are expected by HBaseStorageHandler to discover the HBase services.

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/vkorukanti/drill DRILL-3739

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/drill/pull/215.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #215


        commit 60dfac886a01f53ed94ab146bedbb16fdc90427f
        Author: vkorukanti <venki.korukanti@gmail.com>
        Date: 2015-10-19T18:35:09Z

        DRILL-3938: Support reading from Hive tables that have schema altered after the creation

        Also:
        + Remove "redoRecord" logic which is not needed after "automatic reallocation" (DRILL-1960) changes.
        + Remove HiveTestRecordReader. This is incomplete in implementation and not used anywhere. It is currently just
        a burden to maintain with changes in its superclass HiveRecordReader

        commit 2b28eab82f6c34bc7a27c96ddd3caf7371529f7f
        Author: vkorukanti <venki.korukanti@gmail.com>
        Date: 2015-10-20T23:21:09Z

        DRILL-3893: Change Hive metadata cache invalidation policy to "1 min after last write".

        commit 5d35df1b085f7c4add207c3017a08a531da65dee
        Author: vkorukanti <venki.korukanti@gmail.com>
        Date: 2015-10-21T18:01:23Z

        DRILL-3739: Fix issues in reading Hive tables with StorageHandler configuration (eg. Hive-HBase tables)


        rkins Rahul Challapalli added a comment -

        Below is the stacktrace from the logs

        2015-11-20 19:00:27,334 [29b09234-9f38-c43a-36b9-61194f2eed10:foreman] ERROR o.a.drill.exec.work.foreman.Foreman - SYSTEM ERROR: NullPointerException
        
        
        [Error Id: e9fe607e-a066-493e-a985-e60e4b9f8253 on qa-node191.qa.lab:31010]
        org.apache.drill.common.exceptions.UserException: SYSTEM ERROR: NullPointerException
        
        
        [Error Id: e9fe607e-a066-493e-a985-e60e4b9f8253 on qa-node191.qa.lab:31010]
                at org.apache.drill.common.exceptions.UserException$Builder.build(UserException.java:534) ~[drill-common-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman$ForemanResult.close(Foreman.java:742) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman$StateSwitch.processEvent(Foreman.java:841) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman$StateSwitch.processEvent(Foreman.java:786) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.common.EventProcessor.sendEvent(EventProcessor.java:73) [drill-common-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman$StateSwitch.moveToState(Foreman.java:788) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman.moveToState(Foreman.java:894) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman.run(Foreman.java:255) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.0_71]
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.0_71]
                at java.lang.Thread.run(Thread.java:745) [na:1.7.0_71]
        Caused by: org.apache.drill.exec.work.foreman.ForemanException: Unexpected exception during fragment initialization: Internal error: Error while applying rule DrillPushProjIntoScan, args [rel#705:LogicalProject.NONE.ANY([]).[](input=rel#704:Subset#0.ENUMERABLE.ANY([]).[],key=$0,int_col=$1,bigint_col=$2,date_col=$3,time_col=$4,timestamp_col=$5,interval_col=$6,varchar_col=$7,float_col=$8,double_col=$9,bool_col=$10), rel#699:EnumerableTableScan.ENUMERABLE.ANY([]).[](table=[hive, crosssources, fewtypes_null_hbase])]
                ... 4 common frames omitted
        Caused by: java.lang.AssertionError: Internal error: Error while applying rule DrillPushProjIntoScan, args [rel#705:LogicalProject.NONE.ANY([]).[](input=rel#704:Subset#0.ENUMERABLE.ANY([]).[],key=$0,int_col=$1,bigint_col=$2,date_col=$3,time_col=$4,timestamp_col=$5,interval_col=$6,varchar_col=$7,float_col=$8,double_col=$9,bool_col=$10), rel#699:EnumerableTableScan.ENUMERABLE.ANY([]).[](table=[hive, crosssources, fewtypes_null_hbase])]
                at org.apache.calcite.util.Util.newInternal(Util.java:792) ~[calcite-core-1.4.0-drill-r8.jar:1.4.0-drill-r8]
                at org.apache.calcite.plan.volcano.VolcanoRuleCall.onMatch(VolcanoRuleCall.java:251) ~[calcite-core-1.4.0-drill-r8.jar:1.4.0-drill-r8]
                at org.apache.calcite.plan.volcano.VolcanoPlanner.findBestExp(VolcanoPlanner.java:808) ~[calcite-core-1.4.0-drill-r8.jar:1.4.0-drill-r8]
                at org.apache.calcite.tools.Programs$RuleSetProgram.run(Programs.java:303) ~[calcite-core-1.4.0-drill-r8.jar:1.4.0-drill-r8]
                at org.apache.calcite.prepare.PlannerImpl.transform(PlannerImpl.java:303) ~[calcite-core-1.4.0-drill-r8.jar:1.4.0-drill-r8]
                at org.apache.drill.exec.planner.sql.handlers.DefaultSqlHandler.doLogicalPlanning(DefaultSqlHandler.java:542) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.planner.sql.handlers.DefaultSqlHandler.convertToDrel(DefaultSqlHandler.java:218) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.planner.sql.handlers.DefaultSqlHandler.convertToDrel(DefaultSqlHandler.java:252) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.planner.sql.handlers.DefaultSqlHandler.getPlan(DefaultSqlHandler.java:172) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.planner.sql.DrillSqlWorker.getPlan(DrillSqlWorker.java:197) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman.runSQL(Foreman.java:909) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.work.foreman.Foreman.run(Foreman.java:244) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                ... 3 common frames omitted
        Caused by: java.lang.NullPointerException: null
                at java.lang.Class.forName0(Native Method) ~[na:1.7.0_71]
                at java.lang.Class.forName(Class.java:191) ~[na:1.7.0_71]
                at org.apache.drill.exec.store.hive.HiveScan.splitInput(HiveScan.java:200) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.hive.HiveScan.getSplits(HiveScan.java:178) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.hive.HiveScan.access$000(HiveScan.java:70) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.hive.HiveScan$1.run(HiveScan.java:161) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.hive.HiveScan$1.run(HiveScan.java:159) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at java.security.AccessController.doPrivileged(Native Method) ~[na:1.7.0_71]
                at javax.security.auth.Subject.doAs(Subject.java:415) ~[na:1.7.0_71]
                at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1595) ~[hadoop-common-2.7.0-mapr-1506.jar:na]
                at org.apache.drill.exec.store.hive.HiveScan.getSplitsWithUGI(HiveScan.java:159) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.hive.HiveScan.<init>(HiveScan.java:127) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.hive.HiveStoragePlugin.getPhysicalScan(HiveStoragePlugin.java:82) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.hive.HiveStoragePlugin.getPhysicalScan(HiveStoragePlugin.java:45) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.store.AbstractStoragePlugin.getPhysicalScan(AbstractStoragePlugin.java:58) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.planner.logical.DrillTable.getGroupScan(DrillTable.java:72) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.drill.exec.planner.logical.DrillPushProjIntoScan.onMatch(DrillPushProjIntoScan.java:57) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
                at org.apache.calcite.plan.volcano.VolcanoRuleCall.onMatch(VolcanoRuleCall.java:228) ~[calcite-core-1.4.0-drill-r8.jar:1.4.0-drill-r8]
                ... 13 common frames omitted
        

        If this stack trace looks different, I can file a new jira.

        khfaraaz Khurram Faraaz added a comment -

        Stack trace above is same as that reported in DRILL-4097.

        mehant Mehant Baid added a comment -

        +1.

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/drill/pull/215

        knguyen Krystal added a comment -

        git.commit.id.abbrev=b906811

        Queries against hive hbase tables fail with the following error from sqlline:
        select * from hbase_voter limit 2;
        Error: SYSTEM ERROR: NullPointerException

        Here is the stack trace:

        2015-12-15 10:57:17,524 [298f9d72-0fa1-8d3b-8bc4-130141005e0f:foreman] INFO  o.a.drill.exec.work.foreman.Foreman - Query text for query id 298f9d72-0fa1-8d3b-8bc4-130141005e0f: select * from hbase_voter limit 2
        2015-12-15 10:57:17,960 [298f9d72-0fa1-8d3b-8bc4-130141005e0f:foreman] ERROR o.a.drill.exec.work.foreman.Foreman - SYSTEM ERROR: NullPointerException
        
        
        [Error Id: 4dbcc70a-0911-48ff-97fe-0478d160e63a on mfs41.qa.lab:31010]
        org.apache.drill.common.exceptions.UserException: SYSTEM ERROR: NullPointerException
        
        
        [Error Id: 4dbcc70a-0911-48ff-97fe-0478d160e63a on mfs41.qa.lab:31010]
        	at org.apache.drill.common.exceptions.UserException$Builder.build(UserException.java:534) ~[drill-common-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman$ForemanResult.close(Foreman.java:742) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman$StateSwitch.processEvent(Foreman.java:841) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman$StateSwitch.processEvent(Foreman.java:786) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.common.EventProcessor.sendEvent(EventProcessor.java:73) [drill-common-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman$StateSwitch.moveToState(Foreman.java:788) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman.moveToState(Foreman.java:894) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman.run(Foreman.java:255) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.0_45]
        	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.0_45]
        	at java.lang.Thread.run(Thread.java:744) [na:1.7.0_45]
        Caused by: org.apache.drill.exec.work.foreman.ForemanException: Unexpected exception during fragment initialization: null
        	... 4 common frames omitted
        Caused by: java.lang.NullPointerException: null
        	at java.lang.Class.forName0(Native Method) ~[na:1.7.0_45]
        	at java.lang.Class.forName(Class.java:190) ~[na:1.7.0_45]
        	at org.apache.drill.exec.planner.sql.logical.ConvertHiveParquetScanToDrillParquetScan.getInputFormatFromSD(ConvertHiveParquetScanToDrillParquetScan.java:136) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.planner.sql.logical.ConvertHiveParquetScanToDrillParquetScan.matches(ConvertHiveParquetScanToDrillParquetScan.java:94) ~[drill-storage-hive-core-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.calcite.plan.volcano.VolcanoRuleCall.matchRecurse(VolcanoRuleCall.java:282) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoRuleCall.match(VolcanoRuleCall.java:267) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.fireRules(VolcanoPlanner.java:1522) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.registerImpl(VolcanoPlanner.java:1807) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.register(VolcanoPlanner.java:1017) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.ensureRegistered(VolcanoPlanner.java:1037) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.ensureRegistered(VolcanoPlanner.java:117) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.rel.AbstractRelNode.onRegister(AbstractRelNode.java:305) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.registerImpl(VolcanoPlanner.java:1658) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.register(VolcanoPlanner.java:1017) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.ensureRegistered(VolcanoPlanner.java:1037) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.ensureRegistered(VolcanoPlanner.java:117) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.rel.AbstractRelNode.onRegister(AbstractRelNode.java:305) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.registerImpl(VolcanoPlanner.java:1658) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.register(VolcanoPlanner.java:1017) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.ensureRegistered(VolcanoPlanner.java:1037) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.ensureRegistered(VolcanoPlanner.java:117) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.rel.AbstractRelNode.onRegister(AbstractRelNode.java:305) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.registerImpl(VolcanoPlanner.java:1658) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.register(VolcanoPlanner.java:1017) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.ensureRegistered(VolcanoPlanner.java:1037) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.plan.volcano.VolcanoPlanner.changeTraits(VolcanoPlanner.java:702) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.tools.Programs$RuleSetProgram.run(Programs.java:300) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.calcite.prepare.PlannerImpl.transform(PlannerImpl.java:313) ~[calcite-core-1.4.0-drill-r10.jar:1.4.0-drill-r10]
        	at org.apache.drill.exec.planner.sql.handlers.DefaultSqlHandler.convertToPrel(DefaultSqlHandler.java:281) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.planner.sql.handlers.DefaultSqlHandler.getPlan(DefaultSqlHandler.java:175) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.planner.sql.DrillSqlWorker.getPlan(DrillSqlWorker.java:197) ~[drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman.runSQL(Foreman.java:909) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	at org.apache.drill.exec.work.foreman.Foreman.run(Foreman.java:244) [drill-java-exec-1.4.0-SNAPSHOT.jar:1.4.0-SNAPSHOT]
        	... 3 common frames omitted
        
        zfong Zelaine Fong added a comment -

        Mehant Baid - can you please take a look. Per Krystal's findings, this looks like a regression, so we should try and get this fixed. Thanks.

        githubbot ASF GitHub Bot added a comment -

        GitHub user vkorukanti opened a pull request:

        https://github.com/apache/drill/pull/312

        DRILL-3739: (part 2) Fix issues in reading Hive tables with StorageHa…

        …ndler configuration (eg. Hive-HBase tables)

        Same issue (StorageHandler based tables don't store InputFormat class in MetaStore), but this particular instance reproes when Hive native reader is enabled (store.hive.optimize_scan_with_native_readers = true).

        Added unititest.

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/vkorukanti/drill DRILL-3739

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/drill/pull/312.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #312


        commit 76f41e18207e3e3e987fef56ee7f1695dd6ddd7a
        Author: vkorukanti <venki@stealthsec.com>
        Date: 2015-12-29T09:29:05Z

        DRILL-3739: (part 2) Fix issues in reading Hive tables with StorageHandler configuration (eg. Hive-HBase tables)


        githubbot ASF GitHub Bot added a comment -

        Github user mehant commented on the pull request:

        https://github.com/apache/drill/pull/312#issuecomment-168060723

        +1

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/drill/pull/312

        mehant Mehant Baid added a comment -

        Fixed in 76f41e18207e3e3e987fef56ee7f1695dd6ddd7a

        knguyen Krystal added a comment -

        git.commit.id.abbrev=3d0b4b0

        Verified that bug is fixed.

        knguyen Krystal added a comment -

        Verified.


          People

          • Assignee:
            venki387 Venki Korukanti
            Reporter:
            ckran ckran
            Reviewer:
            Krystal
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development