Uploaded image for project: 'Apache Drill'
  1. Apache Drill
  2. DRILL-360

Enhance HashFunctions to handle null values

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.4.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently, the HashFunctions class uses the NullHandling semantics of NULL_IF_NULL which means it will produce null value for a null input. In order for Drill operators that perform hashing to work correctly with null inputs, we need to add appropriate handling in the HashFunctions such that they produce integer values (e.g 0) for such inputs.

        Issue Links

          Activity

          amansinha100 Aman Sinha added a comment -

          ok, np. You can close 360 as a duplicate of the one you created.

          Aman

          jaltekruse Jason Altekruse added a comment -

          Did not realize a JIRA had already been created


            People

            • Assignee:
              jaltekruse Jason Altekruse
              Reporter:
              amansinha100 Aman Sinha
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development