Uploaded image for project: 'Apache Drill'
  1. Apache Drill
  2. DRILL-3032

Join between complex (nested repeated lists) data results in "LATE type is not supported"

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: 1.1.0
    • Component/s: Execution - Data Types
    • Labels:
      None

      Description

      git.commit.id.abbrev=4689468

      Data Set 1 :

      {
        "id":1,
        "aaa":[[["aa0 1"], ["ab0 1"]]]
      }
      

      Data Set 2 :

      {"id" : 1}
      

      The below query fails

      0: jdbc:drill:schema=dfs_eea> select * from `file1.json` f1 inner join `file2.json` f2 on f1.id = f2.id;
      Error: SYSTEM ERROR: java.lang.UnsupportedOperationException: LATE type is not supported. Mode: OPTIONAL
      
      Fragment 0:0
      
      [Error Id: a865954d-dd29-42fc-8538-291a835a79cd on qa-node190.qa.lab:31010] (state=,code=0)
      

      Attached the error logs

        Attachments

        1. error.log
          6 kB
          Rahul Challapalli

          Issue Links

            Activity

              People

              • Assignee:
                hgunes Hanifi Gunes
                Reporter:
                rkins Rahul Challapalli
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: