Apache Drill
  1. Apache Drill
  2. DRILL-1191

C client returns duplicate rows for hbase records at begin/end of a region

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 0.5.0
    • Component/s: Client - ODBC
    • Labels:
      None

      Description

      git.commit.id.abbrev=e5c2da0

      I have an hbase table that is split in multiple regions. When I perform a select against this table via odbc, it returns duplicate rows with key at the begin/end of a region.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        28d 6h 29m 1 Parth Chandra 22/Aug/14 06:45
        Resolved Resolved Closed Closed
        238d 14h 33m 1 Krystal 17/Apr/15 21:19
        Krystal made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Krystal added a comment -

        No longer reproducible.

        Tony Stevenson made changes -
        Workflow no-reopen-closed, patch-avail, testing [ 12877726 ] Drill workflow [ 12933723 ]
        Parth Chandra made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Parth Chandra added a comment -

        The other issues related to complex types are covered in DRILL-1303. This issue is not in the C++ client library as the data is being returned to the application callback correctly.
        Closing the issue since this is not reproducible in Drill.

        Mehant Baid added a comment -

        We are returning the correct number of records while using the C++ client (no ODBC). Parth has identified a couple of other issues with complex types which he wants to fix before confirming its an ODBC issue.

        Mehant Baid made changes -
        Assignee Mehant Baid [ mehant ] Parth Chandra [ parthc ]
        Jacques Nadeau added a comment -

        This is likely due to something independent of the client used.

        Jacques Nadeau made changes -
        Assignee Mehant Baid [ mehant ]
        Jacques Nadeau made changes -
        Field Original Value New Value
        Fix Version/s 0.5.0 [ 12324880 ]
        Krystal created issue -

          People

          • Assignee:
            Parth Chandra
            Reporter:
            Krystal
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development