Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.5.0
    • Component/s: Functions - Drill
    • Labels:
      None

      Description

      git.commit.id.abbrev=79c1502
      git.commit.id=79c1502c1e96596d4db302c2dd1c9f78d0f4d43d

      /root/open-source-drill-test/testing/framework/resources/drill-smoke/tpch-smoke-passing/testcases/join06-merge.q :
      alter session set `planner.enable_hashjoin` = false

      /root/open-source-drill-test/testing/framework/resources/drill-smoke/tpch-smoke-passing/testcases/join06-merge.q :

      select count
      from supplier s
      join lineitem l on s.s_suppkey = l.l_suppkey
      join orders o on o.o_orderkey = l.l_orderkey
      where l.l_shipdate between date '1995-01-01' and date '1995-12-31'

      /root/open-source-drill-test/testing/framework/resources/drill-smoke/tpch-smoke-passing/testcases/join06-merge.q :

      alter session set `planner.enable_hashjoin` = true

      Expected number of rows: 1
      Actual number of rows from Drill: 1
      Number of matching rows: 0
      Number of rows missing: 1
      Number of rows unexpected: 1

      These rows are not expected (first 10):
      8769

      These rows are missing (first 10):
      8773 (1 time(s))

      Likewise for /root/open-source-drill-test/testing/framework/resources/drill-smoke/tpch-smoke-passing/testcases/join02-merge.q :

      select count
      from (select c.c_custkey
      from customer c, orders o
      where c.c_custkey = o.o_custkey) as foo

      These rows are not expected (first 10):
      14990

      These rows are missing (first 10):
      15000 (1 time(s))

      Note that it makes no difference whether planner.enable_broadcast_join is turned on or off.

      1. DRILL-1063.patch
        1 kB
        Steven Phillips

        Activity

        Rahul Challapalli added a comment -

        Verifed. Below is the testcase

        Functional/Passing/tpch-smoke/join02-merge.q

        Zhiyong Liu added a comment -

        Verified on git.commit.id.abbrev=757e9a2

        Jacques Nadeau added a comment -

        Resolved by 8c66525 or earlier.

        Ramana Inukonda Nagaraj added a comment -

        Marking as critical since this is a regression and part of a smoke test suite.


          People

          • Assignee:
            DrillCommitter
            Reporter:
            Zhiyong Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development