Maven Doxia
  1. Maven Doxia
  2. DOXIA-98

If no urls found in pom hierarchy site failed with NPE

    Details

      Description

      Hi,
      Trying to add some skinning in plexus-components.
      As there is no url defined in any poms hierarchy the site failed.
      A simple workaround is to add an url in a pom.

      Olivier

      1. DOXIA-98
        7 kB
        Olivier Lamy (*$^¨%`£)

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          105d 3h 30m 1 Olivier Lamy (*$^¨%`£) 01/Jun/07 17:16
          Mark Thomas made changes -
          Workflow jira [ 12957364 ] Default workflow, editable Closed status [ 12994310 ]
          Mark Thomas made changes -
          Link This issue relates to MSITE-180 [ MSITE-180 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 23:17:25 UTC 2015 [ 1428275845026 ]
          Mark Thomas made changes -
          Workflow jira [ 12719552 ] Default workflow, editable Closed status [ 12748485 ]
          Mark Thomas made changes -
          Link This issue relates to MSITE-180 [ MSITE-180 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 09:30:24 UTC 2015 [ 1428226224715 ]
          Benjamin Bentmann made changes -
          Link This issue relates to MSITE-180 [ MSITE-180 ]
          Dennis Lundberg made changes -
          Fix Version/s 1.0-alpha-9 [ 13220 ]
          Olivier Lamy (*$^¨%`£) made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Olivier Lamy (*$^¨%`£) added a comment -

          Cannot reproduce with last snapshot.

          Olivier Lamy (*$^¨%`£) added a comment -

          Hi,
          Don't really understand ?
          The attached patch was made on rev 508384.
          It looks since this rev some refactoring has been done.
          But the problem doens't look to be solved with the last snapshot deployed.
          checkout plexus-utils (remove the line with <url>...</url> in the pom)
          And try mvn clean site. I have just try this with apache snapshot repo in my settings and the site build failed.

          Then I have try to reproduce the trouble with a doxia build from the actual trunk.
          But I can't build doxia :
          XmlWriterXdocSink.java:[567,30] replace(char,char) in java.lang.String cannot be applied to (java.lang.String,java.lang.String)

          Jason van Zyl added a comment -

          Can't do much with an .exe file.

          Olivier Lamy (*$^¨%`£) made changes -
          Field Original Value New Value
          Attachment DOXIA-98 [ 25763 ]
          Olivier Lamy (*$^¨%`£) added a comment -

          Patch attached.

          Olivier Lamy (*$^¨%`£) created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Olivier Lamy (*$^¨%`£)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development