Uploaded image for project: 'Maven Doxia'
  1. Maven Doxia
  2. DOXIA-153

HTML tags in twiki not rendered correctly

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-alpha-9
    • Fix Version/s: 1.1
    • Component/s: Module - Twiki
    • Labels:
      None

      Description

      TWiki formatting rules (http://twiki.org/cgi-bin/view/TWiki/TextFormattingRules) state that html tags may be included in a Twiki Page. In some cases, this is required to achieve certain effects. See the description of Verbatim Mode, where it says that <pre>...</pre> should be used in certain cases.

      However, when running the mvn site on .twiki files, all "<" and ">" are replaced by "<" and ">

      Steps to reproduce:
      Create a maven site project.
      Add a .twiki file with the following content:

      ---+ Twiki test

      <pre>
      Hello
      Hello
      </pre>

      After the site has been generated, no <pre> tags will exist instead the following will be shown:

      <pre>Hello Hello</pre>

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                siveton Siveton Vincent
                Reporter:
                alexanderhars Alexander Hars
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: