Uploaded image for project: 'Qpid Dispatch'
  1. Qpid Dispatch
  2. DISPATCH-1582

Prepare Routing Protocol for Backward Compatibility

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • None
    • 1.11.0
    • Routing Engine
    • None

    Description

      In anticipation of moving to routing protocol version 2 (we're currently on 1), there are a few changes needed to make it easy for version 2 to be backward compatible to version 1.  This Jira will track those changes.

      The proposed change is to ensure that a version 1 router ignores version >1 messages, issuing a low-volume warning log when one is received.  This way, a version 2 router can send both versions or send targeted versions based on its knowledge of peer routers protocol versions.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            tross Ted Ross
            tross Ted Ross
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment