Uploaded image for project: 'Qpid Dispatch'
  1. Qpid Dispatch
  2. DISPATCH-1149

authz plugin can no longer override conf file policy

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 1.4.1
    • None
    • None

    Description

      If enabled, the authz plugin should be allowed to defined the valid sources and targets for a given connection and this should take precedence over anything in the policy file (which may still be used for quotas).

      This was (I believe) an unintentional regression by https://github.com/apache/qpid-dispatch/commit/dc981ecc6cf31d8c605e84703a589553281281c2#diff-adc0a0fef2880417cb24cb072363fc29 which reverted the necessary change made in https://github.com/apache/qpid-dispatch/commit/eed8bb65497b23e512072f5ea9fefd8ed73921ef#diff-adc0a0fef2880417cb24cb072363fc29

      Attachments

        Activity

          People

            gsim Gordon Sim
            gsim Gordon Sim
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: