Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-993

Directory studio stops after a few commands issued

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M8 (2.0.0.v20130628)
    • Component/s: None
    • Labels:
      None
    • Environment:
      Mac OSX Mavericks, java build 1.7.0_65-b17

      Description

      After a few command (change, listing) app stop responding and rainbow ball turns... only way is to force application to quit.

      1. apachedsstudio.bak_0.log
        1002 kB
        Ryan Naylor
      2. apachedsstudio.configuration.log
        96 kB
        Ryan Naylor
      3. apachedsstudio.log
        638 kB
        Ryan Naylor
      4. LogApache
        817 kB
        Frédéric Goudal

        Activity

        bignay2000 Ryan Naylor added a comment - - edited

        Yosemite with Java 8, ApacheDS studio is basically unusable. See attached logs and configs.

        elecharny Emmanuel Lecharny added a comment -

        Seems like we can't create the TreeViewer. Assuming Studio is working well on Mavericks, there must be something wrong with Yosemite. To be investigated.

        elecharny Emmanuel Lecharny added a comment -

        What would be helpful is to give us the exact sequence used to reproduce the pb (ie, opening a connection, browsing this, adding that, etc).

        frederic.goudal@bordeaux-inp.fr Frédéric Goudal added a comment -

        Well...

        Finally I have « solved » the problem by removing all the preferences and starting again from scracth. Now it works smoothly (still on mavericks btw)

        f.g.

        frederic.goudal@bordeaux-inp.fr Frédéric Goudal added a comment -

        Ok... the problem just starts again today...

        I'l try to note what I was doing.
        Last time, I was inserting an attribute in an object.. but it may vary a lot.
        I wonder if it has something to do with caching...

        f.g.

        bignay2000 Ryan Naylor added a comment - - edited

        Launch ApacheDS.
        Open Connection
        Expend dc =mycompany, dc=net
        Click on ou=groups
        Click on ou= users
        Expand ou=users tree
        Click on a user
        Click on ou=groups
        Hangs

        Crashed several times when trying to add a givenName to 18 users, I was able to update about 4 users then crash. Force quit. reopen, 4 more, then crash, force quit....

        bignay2000 Ryan Naylor added a comment -

        What are the steps to remove all preferences? Their a plist file somewhere?

        elecharny Emmanuel Lecharny added a comment -

        The Treeviewer NPE has been handled with http://svn.apache.org/viewvc?rev=1440877&view=rev back in jan 2013...

        We badly need a release !

        frederic.goudal@bordeaux-inp.fr Frédéric Goudal added a comment -

        Finally I have found the logs and I join the crash log from my Apache Directory Studio hanging...

        elecharny Emmanuel Lecharny added a comment - - edited

        Frédéric, seems like the issue is really the NPE in
        org.apache.directory.studio.ldapbrowser.ui.editors.entry.EntryEditorOutlinePage.refresh(EntryEditorOutlinePage.java:232)

        which has been fixed in trunk.

        Although I found this error :

        java.lang.Exception: [LDAP: error code 80 - no structuralObjectClass operational attribute]
        	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.checkResponse(DirectoryApiConnectionWrapper.java:1280)
        

        which is weird : that means you are getting an entry which is not correct (it does not have a Structural ObjectClass). Do you have a copy of this entry ?

        frederic.goudal@bordeaux-inp.fr Frédéric Goudal added a comment -

        Well I don't really understand what is NPE... how can I download the fixed version ?

        Yes... I have some strange problem with my ldap server but I think it has nothing to do with apache diretory studio... and the last crash occured while I was correcting this error.

        f.g.

        elecharny Emmanuel Lecharny added a comment -

        NPE = NullPointerException

        seelmann Stefan Seelmann added a comment -

        NPE is fixed. Upcoming release 2.0.0-M9 works on Yosemite.


          People

          • Assignee:
            Unassigned
            Reporter:
            goudal Fredéric Goudal
          • Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development