Details

      Description

      The Image Editor does work correctly.

      LDAP object contains jpegphoto in resolution 390 x 528 points.

      In the version 1.5.3, LDAP browser can detect correct resolution and shows 390x528 and if the image editor starts it shows description 390x528, but it shows only 322x240. Is it bug or is it feature to show only small part of image?

      Regards,

      Robert Wolf.

        Issue Links

          Activity

          Pierre-Arnaud Marcelot made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Pierre-Arnaud Marcelot made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.0.0-M4 [ 12320241 ]
          Fix Version/s 2.0.0 [ 12314306 ]
          Resolution Fixed [ 1 ]
          Hide
          Pierre-Arnaud Marcelot added a comment -
          Show
          Pierre-Arnaud Marcelot added a comment - Fixed at revision 1398743. http://svn.apache.org/viewvc?rev=1398743&view=rev
          Hide
          Pierre-Arnaud Marcelot added a comment -

          Hi Robert,

          Actually that's a feature as we resize the image before displaying it.

          As I fixed other display issues in the Image Editor on OS X, I also increased our maximum width and height for the image preview to 400 pixels.
          Also, we are now using the graphical context (GC) to have a better looking resized image (with interpolation set to high).

          Show
          Pierre-Arnaud Marcelot added a comment - Hi Robert, Actually that's a feature as we resize the image before displaying it. As I fixed other display issues in the Image Editor on OS X, I also increased our maximum width and height for the image preview to 400 pixels. Also, we are now using the graphical context (GC) to have a better looking resized image (with interpolation set to high).
          Pierre-Arnaud Marcelot made changes -
          Fix Version/s 2.0.0-M3 [ 12319488 ]
          Pierre-Arnaud Marcelot made changes -
          Description The Image Editor does work correctly.

          LDAP object contains jpegphoto in resolution 390 x 528 points.

          In the version 1.5.3, LDAP browser can detect correct resolution and shows 390x528 and if the image editor starts it shows description 390x528, but it shows only 322x240. Is it bug or is it feature to show only small part of image?

          In the version 2.0.0-M1, if the jpegphoto is handled using image editor, the ldap browser shows "invalid image" and the size is nearly as twice big as original.

          Thank you for correction to at least the same functionality as in version 1.5.3.

          Regards,

          Robert Wolf.
          The Image Editor does work correctly.

          LDAP object contains jpegphoto in resolution 390 x 528 points.

          In the version 1.5.3, LDAP browser can detect correct resolution and shows 390x528 and if the image editor starts it shows description 390x528, but it shows only 322x240. Is it bug or is it feature to show only small part of image?

          Regards,

          Robert Wolf.
          Hide
          Pierre-Arnaud Marcelot added a comment -

          Cloned issue and edited the description to match the issue.

          Show
          Pierre-Arnaud Marcelot added a comment - Cloned issue and edited the description to match the issue.
          Pierre-Arnaud Marcelot made changes -
          Field Original Value New Value
          Link This issue is a clone of DIRSTUDIO-764 [ DIRSTUDIO-764 ]
          Robert Wolf created issue -

            People

            • Assignee:
              Pierre-Arnaud Marcelot
              Reporter:
              Robert Wolf
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development