Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-733

Error while reading RootDSE on Sun One directory server

    Details

      Description

      I have the following error when Apache Directory Studio try to read RootDSE on Sun One directory server :

      Une erreur est survenue lors de l'ouverture de la connexion

      • L'attribut existe déjà !
        java.lang.NullPointerException
        at org.apache.directory.studio.ldapbrowser.core.jobs.SearchRunnable.initFlags(SearchRunnable.java:754)
        at org.apache.directory.studio.ldapbrowser.core.jobs.SearchRunnable.searchAndUpdateModel(SearchRunnable.java:350)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeRootDSERunnable.loadRootDSE(InitializeRootDSERunnable.java:180)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeAttributesRunnable.initializeAttributes(InitializeAttributesRunnable.java:217)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeAttributesRunnable.initializeAttributes(InitializeAttributesRunnable.java:195)
        at org.apache.directory.studio.ldapbrowser.core.BrowserConnectionListener.openBrowserConnection(BrowserConnectionListener.java:118)
        at org.apache.directory.studio.ldapbrowser.core.BrowserConnectionListener.connectionOpened(BrowserConnectionListener.java:65)
        at org.apache.directory.studio.connection.core.jobs.OpenConnectionsRunnable.runNotification(OpenConnectionsRunnable.java:132)
        at org.apache.directory.studio.connection.core.jobs.StudioConnectionJob.run(StudioConnectionJob.java:120)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
        java.lang.NullPointerException
        java.lang.IllegalArgumentException: L'attribut existe déjà !
        at org.apache.directory.studio.ldapbrowser.core.model.impl.AbstractEntry.addAttribute(AbstractEntry.java:178)
        at org.apache.directory.studio.ldapbrowser.core.jobs.SearchRunnable.initFlags(SearchRunnable.java:705)
        at org.apache.directory.studio.ldapbrowser.core.jobs.SearchRunnable.searchAndUpdateModel(SearchRunnable.java:350)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeRootDSERunnable.loadRootDSE(InitializeRootDSERunnable.java:186)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeAttributesRunnable.initializeAttributes(InitializeAttributesRunnable.java:217)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeAttributesRunnable.initializeAttributes(InitializeAttributesRunnable.java:195)
        at org.apache.directory.studio.ldapbrowser.core.BrowserConnectionListener.openBrowserConnection(BrowserConnectionListener.java:118)
        at org.apache.directory.studio.ldapbrowser.core.BrowserConnectionListener.connectionOpened(BrowserConnectionListener.java:65)
        at org.apache.directory.studio.connection.core.jobs.OpenConnectionsRunnable.runNotification(OpenConnectionsRunnable.java:132)
        at org.apache.directory.studio.connection.core.jobs.StudioConnectionJob.run(StudioConnectionJob.java:120)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

      L'attribut existe déjà !

        Activity

        Hide
        Pierre-Arnaud Marcelot added a comment -

        After some debugging, I found out that the cause of this issue was that the server was not correctly exporting its schema in the subSchemaSubEntry.
        More specifically, the 'objectClass' attribute type is assigned a bogus 'objectclass-oid' string OID:
        attributetypes: ( objectclass-oid NAME 'objectclass' DESC 'Standard Attribut
        e' SYNTAX '1.3.6.1.4.1.1466.115.121.1.15' )

        This was causing some issue in Studio's code because we relied on that OID for some matching.

        Show
        Pierre-Arnaud Marcelot added a comment - After some debugging, I found out that the cause of this issue was that the server was not correctly exporting its schema in the subSchemaSubEntry. More specifically, the 'objectClass' attribute type is assigned a bogus 'objectclass-oid' string OID: attributetypes: ( objectclass-oid NAME 'objectclass' DESC 'Standard Attribut e' SYNTAX '1.3.6.1.4.1.1466.115.121.1.15' ) This was causing some issue in Studio's code because we relied on that OID for some matching.
        Hide
        Pierre-Arnaud Marcelot added a comment -
        Show
        Pierre-Arnaud Marcelot added a comment - Fixed at revision 1236162. http://svn.apache.org/viewvc?rev=1236162&view=rev
        Hide
        Pierre-Arnaud Marcelot added a comment -

        Version 2.0.0-M2 has been released.

        Show
        Pierre-Arnaud Marcelot added a comment - Version 2.0.0-M2 has been released.

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Mathieu Roullet
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development