Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-609

Studio "hangs" when performing large search that is to be displayed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5.2
    • Fix Version/s: 1.5.3
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Windows 7 64-bit, 6GB RAM

      Description

      Hello,
      Today I needed to perform some large searches against Microsoft AD and Novell eDirectory. The AD search gave me about 29000 results and the eDirectory search gave me 33000 results.
      The fetching part of the search works just fine but after fetching it seems that Studio goes into "Not responding" mode for over 15 minutes before I killed it, and sits there trying to display all those results, is there a limit over which I should not perform searches in Studio?
      I can mention that the same search works fine when doing a direct export to LDIF and not displaying the results on screen.

        Activity

        Pierre-Arnaud Marcelot added a comment -

        Version 1.5.3 has been release.
        Let's close this issue.

        Stefan Seelmann added a comment -

        The main issue is solved, search result entries are no more cloned in the search result editor: http://svn.apache.org/viewvc?rev=928904&view=rev

        I created a new Jira to improve the general handling of large data sets: DIRSTUDIO-645

        Stefan Seelmann added a comment -

        The problem is that we create a clone of the whole search result in the search result edtior. This costs lot of CPU and RAM.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Aleks M
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development