Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.5.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      java.runtime.name=Java(TM) SE Runtime Environment
      java.runtime.version=1.6.0_15-b03
      Windows 7 - Build 7100

      Description

      ObjectGUID (and ObjectSID) properties both display as Invalid Data

      These are very useful attributes for debugging links. IIRC these used to display in the past but I've probably done a few upgrades since.

        Issue Links

          Activity

          Pierre-Arnaud Marcelot made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Pierre-Arnaud Marcelot added a comment -

          Apache Directory Studio version 1.5.0 has been released.

          Pierre-Arnaud Marcelot made changes -
          Component/s studio-ldapbrowser [ 12311538 ]
          Stefan Seelmann made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Stefan Seelmann [ seelmann ]
          Fix Version/s 1.5.0 [ 12313682 ]
          Resolution Fixed [ 1 ]
          Stefan Seelmann added a comment -

          Added value editors for objectGUID and objectSid to display their string representation.

          Fixed here:
          http://svn.apache.org/viewvc?rev=822212&view=rev
          http://svn.apache.org/viewvc?rev=822618&view=rev

          Stefan Seelmann added a comment -
          • Added syntax 2.5.5.10 to binary syntaxes
          • Added attribute types objectGUID (1.2.840.113556.1.4.2) and objectSid (1.2.840.113556.1.4.146) to binary attributes
          • Also improved process of reading the schema because there was another issue: We read the schema from the server and parse object classes, attribute types, matching rules and syntaxes to schema objects. Active Directory schema only provides object clases and attribute types, but no syntaxes and no matching rules. The problem is that although both objectGUID and objectSid contain a syntax OID it is considered as invalid because the target syntax object does not exist. I fixed that by creating pseudo syntax and matching rule objects in such a case.
          Stefan Seelmann made changes -
          Field Original Value New Value
          Link This issue relates to DIRSTUDIO-434 [ DIRSTUDIO-434 ]
          Jim Birch created issue -

            People

            • Assignee:
              Stefan Seelmann
              Reporter:
              Jim Birch
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development