Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-524

Operational attributes are not show, although enabled under preferences

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.5.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Apache DS 1.0.2, Apache Studio 1.4.0 (official build)

      Description

      Hi

      Although I have enabled the option "show operational attributes" under Preferenes; LDAP, Entry Editior, Attributes like "administrativerole" and "prescriptiveaci" are not show in the entry editor, but are available via the LDIF export, so they are here!

      As I'm not the LDIF guru, an option to use the very nice gui to manage those would be great!

      Maybe I did something wrong, but I couldn't figure out what?!

      Thank you for lending me a hand

      Beat

      1. operational_attributes_2.png
        15 kB
        Stefan Seelmann
      2. operational_attributes.png
        21 kB
        Stefan Seelmann
      3. Proposal for hoover tip for very lazy admins which are left handed ;-).jpg
        33 kB
        Beat Burgener
      4. screenshot-1.jpg
        11 kB
        Beat Burgener

        Activity

        Beat Burgener added a comment -

        Okey, by accident found the "issue".

        Operational attributes are NOT loaded by default, you have to use the "context menu" to enable/tick "Fetch Operational Attributes".

        This is not very "intuitive" to me. Maybe this option should be turned on by default or linked with the "show operational attributes" or
        maybe available as additional option in the options dialog ...

        However, it is clearly not a bug in that sense, sorry for bothering you

        Beat

        Beat Burgener added a comment -

        Well, again me ...

        The option "Fetch Operational Attributes" affects only the level in the tree where you currently are and is not recursive nor does it survive an Studio restart.
        I think a global option to enable fetching operation attributes on a global basis would be cool, but maybe there is one that I didn't find ...

        ThanX

        Beat

        Stefan Seelmann added a comment -

        In former versions of studio, when enabling "show operational attributes" option, the operational attribures were loaded. However there were problems, see DIRSTUDIO-427 for details.

        Now there are two levels on how to fetch operational attributes:

        • per entry: as you already figured out above, by checking the option in the context menu
        • per connection: to fetch operational for the whole connection you could enable the option "Fetch operational attributes while browsing" in the connection properties, tab "Browser Options"
        Beat Burgener added a comment -

        Quick and dirty proposal ...

        Beat Burgener added a comment -

        Stefan,

        thank you for the swift reply. Well, I didn't do enough research though ...

        From your perspective and the issue 427, the place to globally enable this option is fully correct.
        Searching the help does not easily reveal this, as the hit is somewhere on position 13
        and also hidden there ...

        And since enabling the view option did also alter the fetch behavior in former versions, I suggest adding an info
        link to the view preferences screen (see screen shot) to point to an dedicated help/explain
        page or to point to the connection property page ...

        But this is only a suggestion to improve the learning curve of lazy administrators ...

        Thank you

        Beat

        Stefan Seelmann added a comment -

        Hi, Beat,

        I hope my first reply didn't sound too harsh
        You are totally right, we changed the behaviour, because it was totally clear for us when implementing it. Hopefully, feedback like yours help us to not forget our users and provide better release notes etc.

        Thanks for your suggestion about the additional info, that's a great idea. However, I wouldn't use a link because a link is used to jump to other preference pages. Instead I would suggest to either add a tooltip or to print a note directly, see attached scrrenshots. WDYT?

        Beat Burgener added a comment -

        Stefan,

        not at all! Was very easy to understand and also very kind!

        I would vote for the second option to permanently display the info, which in turn might occupy space
        needed for additional options later ....

        I'm not sure how the tooltip text would be displayed if I only tick the check box without hoovering the
        description nor do I have any experience on how this will behave on different OS'es like Mac ...- I'm currently
        using Windoooooof.

        I'm definitively encourage some way to point that out, both options have their advantages and
        disadvantages ...

        Well, maybe a combination of both? What about a yellow exclamation sign displayed at the end of the
        text if this option is ticket which shows the text when hoovered ... but also when hoovered over the text
        itself ... Okey, may be this is to much though ...

        Thank you for following up with this!

        I'll attach a screen shot soon of what I think ...

        Beat

        Stefan Seelmann added a comment -

        I added the permanently displayed info.

        Fixed in trunk:
        http://svn.apache.org/viewvc?rev=807981&view=rev

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory studio version 1.5.0 has been released.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Beat Burgener
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development