Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-456

Cannot create an entry with mandatory binary attribute

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.4.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Windows XP SP2

      Description

      I try to create a new entry thas has a mandatory binary attribute, for example an entry with objectClass=top, person and strongAuthenticationUser

      I set a value for each mandatory attributes which are cn, sn and userCertificate
      When I press Finish button in the New Entry wizard, an error occurs with "Error while creating entry" message, and details are "[LDAP: error code 17 - userCertificate: requires ;binary transfer]"

      The problem is that the mandatory userCertificate attribute description in attribute list is "userCertificate" and not "userCertificate;binary" as it should be. The generated LDIF has not the ";binary" tag, so that the modification is rejected.

      For an optional binary attribute, it is possible to edit attribute description and set the binary option. But this is not available for mandatory attribute.

        Activity

        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.4.0 has been released.

        Pierre-Arnaud Marcelot made changes -
        Component/s studio-ldapbrowser [ 12311538 ]
        Stefan Seelmann made changes -
        Field Original Value New Value
        Assignee Stefan Seelmann [ seelmann ]
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.4.0 [ 12313402 ]
        Resolution Fixed [ 1 ]
        Stefan Seelmann added a comment -

        Now it is possible to rename all attributes

        Stephane Vergnes created issue -

          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Stephane Vergnes
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development