Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-434

Add value editor for Active Directory objectGUID and objectSid attributes

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.5.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      When viewing an Active Directory entry objectGUID attributes are not displayed, and it is also not possible to edit them. Same for objectSid, both have the same syntax OID. The entry editor just shows "Invalid Data" for them.

      The attributes have binary values. They could be displayed either in hex format (and the hex format can be used in searches as well, with a backslash in front of every two hex digits), or using the preferred Microsoft format, which is just the hex format shuffled and delimited with dashes.

      Here are a couple of articles that show how to convert from hex to the Microsoft format:
      http://forums.sun.com/thread.jspa?threadID=646111
      http://blog.joeware.net/2008/05/03/1230/

      (I found this in version 1.3, but this is not listed as a released version)

        Issue Links

          Activity

          Marius Scurtescu created issue -
          Emmanuel Lecharny added a comment -

          The problem is that Microsoft (as usual ...) is using its own syntax. Instead of using the 1.3.6.1.4.1.1466.115.121.1.40 syntax, they defined a specific one (2.5.5.10) under an OID which should not be extended... Anyway, we won't change the way M$ is sabotaging the standards ...

          Let's implement M$ syntaxes. The first step would be to list all of them, in order to avoid doing it again.

          Stefan Zoerner added a comment -

          I recommend to add objectGUID and objectSid to the default list of binary attributes. After that, the ugly "Invalid data" message does not show up. Instead, the value in the browser states "Binary Data (16 Bytes)".

          Implementing an appropriate value editor would be the second step.

          Stefan Seelmann made changes -
          Field Original Value New Value
          Link This issue is related to DIRSTUDIO-527 [ DIRSTUDIO-527 ]
          Stefan Seelmann added a comment -
          • Added syntax 2.5.5.10 to binary syntaxes
          • Added attribute types objectGUID (1.2.840.113556.1.4.2) and objectSid (1.2.840.113556.1.4.146) to binary attributes
          • Also improved process of reading the schema because there was another issue: We read the schema from the server and parse object classes, attribute types, matching rules and syntaxes to schema objects. Active Directory schema only provides object clases and attribute types, but no syntaxes and no matching rules. The problem is that although both objectGUID and objectSid contain a syntax OID it is considered as invalid because the target syntax object does not exist. I fixed that by creating pseudo syntax and matching rule objects in such a case.
          Stefan Seelmann added a comment -

          Here is another article explaining the GUID format: http://alt.pluralsight.com/wiki/default.aspx/SDS/GuidBinding.html

          Stefan Seelmann made changes -
          Summary add value editor for Active Directory objectGUID attributes Add value editor for Active Directory objectGUID and objectSid attributes
          Assignee Stefan Seelmann [ seelmann ]
          Fix Version/s 1.5.0 [ 12313682 ]
          Stefan Seelmann added a comment -

          Added value editors for objectGUID and objectSid to display their string representation.

          Fixed here:
          http://svn.apache.org/viewvc?rev=822212&view=rev
          http://svn.apache.org/viewvc?rev=822618&view=rev

          Stefan Seelmann made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Pierre-Arnaud Marcelot added a comment -

          Apache Directory studio version 1.5.0 has been released.

          Pierre-Arnaud Marcelot made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          305d 7h 21m 1 Stefan Seelmann 07/Oct/09 09:28
          Resolved Resolved Closed Closed
          43d 7h 11m 1 Pierre-Arnaud Marcelot 19/Nov/09 15:39

            People

            • Assignee:
              Stefan Seelmann
              Reporter:
              Marius Scurtescu
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development