Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-427

Operational attributes turned on by itself

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.4.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      Hi
      Working against Novell eDirectory 8.7.3.9

      When I click the New attribute button and add the userPassword attribute Directory Studio automatically turns on the display of operational attributes and I have to go to Preferences>LDAP>Attributes>Entry editor to turn them off again.

        Activity

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.4.0 has been released.

        Stefan Seelmann added a comment -

        Changed operational attribute handling:
        http://svn.apache.org/viewvc?rev=753151&view=rev

        "Show operational attributes" in entry editor now only is a view filter. It is still turned on when adding an operational attribute, but that doesn't cause that operational attributes are fetched from the directory server.

        Now there is a new option in the connection properties to fetch operational attributes for all entries while browsing. When this is disabled there is a new action in the context menu to make it possible to fetch operational attributes for the current entry only.

        Stefan Seelmann added a comment -

        The userPassword attribute is operational, this is the cause why the "Show Operational Attributes" option is turned on:
        ( 2.5.4.35 NAME 'userPassword' DESC 'Internal NDS policy forces this to be single-valued' SYNTAX 1.3.6.1.4.1.1466.115.121.1.40

        {128}

        USAGE directoryOperation )

        Additional the userPassword attribute can only be written, but not read:
        http://www.novell.com/coolsolutions/qna/11893.html

        Stefan Seelmann added a comment -

        There is some 'magic': When "Show Operational Attributes" is turned off and you add an operational attribute or an attribute not specified in the schema then it is turned on automatically.

        Maybe we should rethink about this "Show Operational Attributes" checkbox.

        Currently it has two functions:
        1st: A filter function for the entry editor. When displaying the attributes of an entry there is a check if it is operational. This is the case if the usage differes from "userApplications" or if the attribute type doesn't exist in the schema at all.
        2nd: Whether to fetch operational attributes from the directory or not (add a "+" to the list of returned attributes or not)

        I think it would be better so separate these concerns:

        The "Show Operational Attributes" checkbox should only have the filter function, like the other checkboxes "Show objectClass|must|may attributes".

        Whether to fetch operational attributes from the directory should be configured diffently. I'd like to suggest to add an option in the connection properties for this which fetches operational attributes for each entry. Additional we should make it possible to fetch operational attributes on a per-request basis.

        Thoughts?


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Aleks M
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development