Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-424

Canceling a search gives an error sometimes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.5.3
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      Sometimes when I cancel a search in progress I get errors like this:

      !ENTRY org.apache.directory.studio.connection.ui 4 4 2008-10-30 10:55:53.859
      !MESSAGE
      !STACK 0
      java.lang.reflect.InvocationTargetException
      at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:403)
      at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner.execute(RunnableContextRunner.java:127)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.filterAndSort(SearchResultEditorContentProvider.java:112)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.refresh(SearchResultEditorContentProvider.java:93)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.refreshInput(SearchResultEditorUniversalListener.java:667)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.setInput(SearchResultEditorUniversalListener.java:573)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditor.setInput(SearchResultEditor.java:96)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener$1.selectionChanged(SearchResultEditorUniversalListener.java:127)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker$2.run(AbstractPartSelectionTracker.java:142)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
      at org.eclipse.core.runtime.Platform.run(Platform.java:880)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker.firePostSelection(AbstractPartSelectionTracker.java:140)
      at org.eclipse.ui.internal.WindowPartSelectionTracker$2.selectionChanged(WindowPartSelectionTracker.java:47)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker$2.run(AbstractPartSelectionTracker.java:142)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
      at org.eclipse.core.runtime.Platform.run(Platform.java:880)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker.firePostSelection(AbstractPartSelectionTracker.java:140)
      at org.eclipse.ui.internal.PagePartSelectionTracker$2.selectionChanged(PagePartSelectionTracker.java:52)
      at org.eclipse.jface.viewers.StructuredViewer$3.run(StructuredViewer.java:842)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
      at org.eclipse.core.runtime.Platform.run(Platform.java:880)
      at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:48)
      at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
      at org.eclipse.jface.viewers.StructuredViewer.firePostSelectionChanged(StructuredViewer.java:840)
      at org.eclipse.jface.viewers.StructuredViewer.setSelection(StructuredViewer.java:1639)
      at org.eclipse.jface.viewers.TreeViewer.setSelection(TreeViewer.java:1104)
      at org.apache.directory.studio.ldapbrowser.ui.views.browser.BrowserViewUniversalListener.searchUpdated(BrowserViewUniversalListener.java:451)
      at org.apache.directory.studio.ldapbrowser.core.events.EventRegistry$1.run(EventRegistry.java:139)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:133)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3800)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3425)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.block(ModalContext.java:172)
      at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:370)
      at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner.execute(RunnableContextRunner.java:127)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.filterAndSort(SearchResultEditorContentProvider.java:112)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.refresh(SearchResultEditorContentProvider.java:93)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.refreshInput(SearchResultEditorUniversalListener.java:667)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.searchUpdated(SearchResultEditorUniversalListener.java:529)
      at org.apache.directory.studio.ldapbrowser.core.events.EventRegistry$1.run(EventRegistry.java:139)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:133)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3800)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3425)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2382)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2198)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:488)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.apache.directory.studio.Application.start(Application.java:61)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
      Caused by: java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.compare(SearchResultEditorSorter.java:277)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter$1.compare(SearchResultEditorSorter.java:236)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.sort(SearchResultEditorSorter.java:232)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.FilterAndSortRunnable.run(FilterAndSortRunnable.java:102)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:118)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
      Root exception:
      java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.compare(SearchResultEditorSorter.java:277)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter$1.compare(SearchResultEditorSorter.java:236)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.sort(SearchResultEditorSorter.java:232)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.FilterAndSortRunnable.run(FilterAndSortRunnable.java:102)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:118)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

      !ENTRY org.apache.directory.studio.connection.ui 4 4 2008-10-30 10:55:55.125
      !MESSAGE
      !STACK 0
      java.lang.reflect.InvocationTargetException
      at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:403)
      at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner.execute(RunnableContextRunner.java:127)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.filterAndSort(SearchResultEditorContentProvider.java:112)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.refresh(SearchResultEditorContentProvider.java:93)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.refreshInput(SearchResultEditorUniversalListener.java:667)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.searchUpdated(SearchResultEditorUniversalListener.java:529)
      at org.apache.directory.studio.ldapbrowser.core.events.EventRegistry$1.run(EventRegistry.java:139)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:133)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3800)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3425)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2382)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2198)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:488)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.apache.directory.studio.Application.start(Application.java:61)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
      Caused by: java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.compare(SearchResultEditorSorter.java:277)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter$1.compare(SearchResultEditorSorter.java:236)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.sort(SearchResultEditorSorter.java:232)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.FilterAndSortRunnable.run(FilterAndSortRunnable.java:102)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:118)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
      Root exception:
      java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.compare(SearchResultEditorSorter.java:277)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter$1.compare(SearchResultEditorSorter.java:236)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.sort(SearchResultEditorSorter.java:232)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.FilterAndSortRunnable.run(FilterAndSortRunnable.java:102)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:118)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

      !ENTRY org.eclipse.ui 4 0 2008-10-30 10:55:58.984
      !MESSAGE Unhandled event loop exception
      !STACK 0
      java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.compareRdnValues(BrowserSorter.java:359)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.compare(BrowserSorter.java:302)
      at org.eclipse.jface.viewers.ViewerComparator$1.compare(ViewerComparator.java:187)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.eclipse.jface.viewers.ViewerComparator.sort(ViewerComparator.java:185)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.access$001(BrowserSorter.java:45)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.sort(BrowserSorter.java:93)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSearchResultPage.getChildren(BrowserSearchResultPage.java:105)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserContentProvider.getChildren(BrowserContentProvider.java:396)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren(AbstractTreeViewer.java:1352)
      at org.eclipse.jface.viewers.TreeViewer.getRawChildren(TreeViewer.java:385)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getFilteredChildren(AbstractTreeViewer.java:636)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getSortedChildren(AbstractTreeViewer.java:602)
      at org.eclipse.jface.viewers.AbstractTreeViewer$1.run(AbstractTreeViewer.java:799)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
      at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:776)
      at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeViewer.java:634)
      at org.eclipse.jface.viewers.AbstractTreeViewer.handleTreeExpand(AbstractTreeViewer.java:1442)
      at org.eclipse.jface.viewers.TreeViewer.handleTreeExpand(TreeViewer.java:927)
      at org.eclipse.jface.viewers.AbstractTreeViewer$4.treeExpanded(AbstractTreeViewer.java:1453)
      at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:126)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1027)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1012)
      at org.eclipse.swt.widgets.Tree.wmNotifyChild(Tree.java:7306)
      at org.eclipse.swt.widgets.Control.wmNotify(Control.java:4718)
      at org.eclipse.swt.widgets.Composite.wmNotify(Composite.java:1756)
      at org.eclipse.swt.widgets.Control.WM_NOTIFY(Control.java:4348)
      at org.eclipse.swt.widgets.Control.windowProc(Control.java:3841)
      at org.eclipse.swt.widgets.Display.windowProc(Display.java:4528)
      at org.eclipse.swt.internal.win32.OS.CallWindowProcW(Native Method)
      at org.eclipse.swt.internal.win32.OS.CallWindowProc(OS.java:2273)
      at org.eclipse.swt.widgets.Tree.callWindowProc(Tree.java:1529)
      at org.eclipse.swt.widgets.Tree.WM_LBUTTONDOWN(Tree.java:6249)
      at org.eclipse.swt.widgets.Control.windowProc(Control.java:3822)
      at org.eclipse.swt.widgets.Tree.windowProc(Tree.java:5791)
      at org.eclipse.swt.widgets.Display.windowProc(Display.java:4541)
      at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
      at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2370)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3420)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2382)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2198)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:488)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.apache.directory.studio.Application.start(Application.java:61)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

      !ENTRY org.eclipse.ui 4 0 2008-10-30 10:56:00.734
      !MESSAGE Unhandled event loop exception
      !STACK 0
      java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.compareRdnValues(BrowserSorter.java:359)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.compare(BrowserSorter.java:302)
      at org.eclipse.jface.viewers.ViewerComparator$1.compare(ViewerComparator.java:187)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.eclipse.jface.viewers.ViewerComparator.sort(ViewerComparator.java:185)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.access$001(BrowserSorter.java:45)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.sort(BrowserSorter.java:93)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSearchResultPage.getChildren(BrowserSearchResultPage.java:105)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserContentProvider.getChildren(BrowserContentProvider.java:396)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren(AbstractTreeViewer.java:1352)
      at org.eclipse.jface.viewers.TreeViewer.getRawChildren(TreeViewer.java:385)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getFilteredChildren(AbstractTreeViewer.java:636)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getSortedChildren(AbstractTreeViewer.java:602)
      at org.eclipse.jface.viewers.AbstractTreeViewer$1.run(AbstractTreeViewer.java:799)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
      at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:776)
      at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeViewer.java:634)
      at org.eclipse.jface.viewers.AbstractTreeViewer.handleTreeExpand(AbstractTreeViewer.java:1442)
      at org.eclipse.jface.viewers.TreeViewer.handleTreeExpand(TreeViewer.java:927)
      at org.eclipse.jface.viewers.AbstractTreeViewer$4.treeExpanded(AbstractTreeViewer.java:1453)
      at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:126)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1027)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1012)
      at org.eclipse.swt.widgets.Tree.wmNotifyChild(Tree.java:7306)
      at org.eclipse.swt.widgets.Control.wmNotify(Control.java:4718)
      at org.eclipse.swt.widgets.Composite.wmNotify(Composite.java:1756)
      at org.eclipse.swt.widgets.Control.WM_NOTIFY(Control.java:4348)
      at org.eclipse.swt.widgets.Control.windowProc(Control.java:3841)
      at org.eclipse.swt.widgets.Display.windowProc(Display.java:4528)
      at org.eclipse.swt.internal.win32.OS.CallWindowProcW(Native Method)
      at org.eclipse.swt.internal.win32.OS.CallWindowProc(OS.java:2273)
      at org.eclipse.swt.widgets.Tree.callWindowProc(Tree.java:1529)
      at org.eclipse.swt.widgets.Tree.WM_LBUTTONDOWN(Tree.java:6249)
      at org.eclipse.swt.widgets.Control.windowProc(Control.java:3822)
      at org.eclipse.swt.widgets.Tree.windowProc(Tree.java:5791)
      at org.eclipse.swt.widgets.Display.windowProc(Display.java:4541)
      at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
      at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2370)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3420)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2382)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2198)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:488)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.apache.directory.studio.Application.start(Application.java:61)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

      !ENTRY org.apache.directory.studio.connection.ui 4 4 2008-10-30 10:56:02.843
      !MESSAGE
      !STACK 0
      java.lang.reflect.InvocationTargetException
      at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:403)
      at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner.execute(RunnableContextRunner.java:127)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.filterAndSort(SearchResultEditorContentProvider.java:112)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorContentProvider.refresh(SearchResultEditorContentProvider.java:93)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.refreshInput(SearchResultEditorUniversalListener.java:667)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener.setInput(SearchResultEditorUniversalListener.java:573)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditor.setInput(SearchResultEditor.java:96)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener$1.selectionChanged(SearchResultEditorUniversalListener.java:127)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker$2.run(AbstractPartSelectionTracker.java:142)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
      at org.eclipse.core.runtime.Platform.run(Platform.java:880)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker.firePostSelection(AbstractPartSelectionTracker.java:140)
      at org.eclipse.ui.internal.WindowPartSelectionTracker$2.selectionChanged(WindowPartSelectionTracker.java:47)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker$2.run(AbstractPartSelectionTracker.java:142)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
      at org.eclipse.core.runtime.Platform.run(Platform.java:880)
      at org.eclipse.ui.internal.AbstractPartSelectionTracker.firePostSelection(AbstractPartSelectionTracker.java:140)
      at org.eclipse.ui.internal.PagePartSelectionTracker$2.selectionChanged(PagePartSelectionTracker.java:52)
      at org.eclipse.jface.viewers.StructuredViewer$3.run(StructuredViewer.java:842)
      at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
      at org.eclipse.core.runtime.Platform.run(Platform.java:880)
      at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:48)
      at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
      at org.eclipse.jface.viewers.StructuredViewer.firePostSelectionChanged(StructuredViewer.java:840)
      at org.eclipse.jface.viewers.StructuredViewer.handlePostSelect(StructuredViewer.java:1153)
      at org.eclipse.jface.viewers.StructuredViewer$5.widgetSelected(StructuredViewer.java:1178)
      at org.eclipse.jface.util.OpenStrategy.firePostSelectionEvent(OpenStrategy.java:250)
      at org.eclipse.jface.util.OpenStrategy.access$4(OpenStrategy.java:244)
      at org.eclipse.jface.util.OpenStrategy$3.run(OpenStrategy.java:418)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:133)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3800)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3425)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2382)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2198)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:488)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.apache.directory.studio.Application.start(Application.java:61)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
      Caused by: java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.compare(SearchResultEditorSorter.java:277)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter$1.compare(SearchResultEditorSorter.java:236)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.sort(SearchResultEditorSorter.java:232)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.FilterAndSortRunnable.run(FilterAndSortRunnable.java:102)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:118)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
      Root exception:
      java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.compare(SearchResultEditorSorter.java:277)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter$1.compare(SearchResultEditorSorter.java:236)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorSorter.sort(SearchResultEditorSorter.java:232)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.FilterAndSortRunnable.run(FilterAndSortRunnable.java:102)
      at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:118)
      at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

      !ENTRY org.eclipse.ui 4 0 2008-10-30 10:56:03.765
      !MESSAGE Unhandled event loop exception
      !STACK 0
      java.lang.NullPointerException
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.compareRdnValues(BrowserSorter.java:359)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.compare(BrowserSorter.java:302)
      at org.eclipse.jface.viewers.ViewerComparator$1.compare(ViewerComparator.java:187)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.mergeSort(Unknown Source)
      at java.util.Arrays.sort(Unknown Source)
      at org.eclipse.jface.viewers.ViewerComparator.sort(ViewerComparator.java:185)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.access$001(BrowserSorter.java:45)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSorter.sort(BrowserSorter.java:93)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSearchResultPage.getChildren(BrowserSearchResultPage.java:105)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserSearchResultPage.getParentOf(BrowserSearchResultPage.java:179)
      at org.apache.directory.studio.ldapbrowser.common.widgets.browser.BrowserContentProvider.getParent(BrowserContentProvider.java:252)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getParentElement(AbstractTreeViewer.java:1646)
      at org.eclipse.jface.viewers.TreeViewer.getParentElement(TreeViewer.java:601)
      at org.eclipse.jface.viewers.AbstractTreeViewer.internalExpand(AbstractTreeViewer.java:1573)
      at org.eclipse.jface.viewers.AbstractTreeViewer.reveal(AbstractTreeViewer.java:2229)
      at org.apache.directory.studio.ldapbrowser.ui.views.browser.BrowserView.select(BrowserView.java:247)
      at org.apache.directory.studio.ldapbrowser.ui.actions.OpenSearchResultAction.run(OpenSearchResultAction.java:75)
      at org.apache.directory.studio.ldapbrowser.ui.editors.searchresult.SearchResultEditorUniversalListener$3.linkActivated(SearchResultEditorUniversalListener.java:240)
      at org.eclipse.ui.forms.widgets.AbstractHyperlink.handleActivate(AbstractHyperlink.java:228)
      at org.eclipse.ui.forms.widgets.AbstractHyperlink.handleMouseUp(AbstractHyperlink.java:316)
      at org.eclipse.ui.forms.widgets.AbstractHyperlink.access$2(AbstractHyperlink.java:300)
      at org.eclipse.ui.forms.widgets.AbstractHyperlink$4.handleEvent(AbstractHyperlink.java:119)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3823)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3422)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2382)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2198)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:488)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.apache.directory.studio.Application.start(Application.java:61)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

        Activity

        Aleks M created issue -
        Aleks M added a comment -

        This is the search I aborted:

        (loginTime>=20081024105227Z)

        Stefan Seelmann made changes -
        Field Original Value New Value
        Issue Type Question [ 11 ] Bug [ 1 ]
        Assignee Stefan Seelmann [ seelmann ]
        Fix Version/s 1.5.0 [ 12313682 ]
        Stefan Seelmann added a comment -

        I wasn't able to reproduce. I'll investigate later.

        Stefan Seelmann made changes -
        Fix Version/s 2.0.0 [ 12314306 ]
        Fix Version/s 1.5.0 [ 12313682 ]
        Pierre-Arnaud Marcelot made changes -
        Assignee Stefan Seelmann [ seelmann ] Pierre-Arnaud Marcelot [ pamarcelot ]
        Fix Version/s 1.5.3 [ 12314458 ]
        Fix Version/s 2.0.0 [ 12314306 ]
        Pierre-Arnaud Marcelot made changes -
        Component/s studio-ldapbrowser [ 12311538 ]
        Pierre-Arnaud Marcelot added a comment -

        I was not able to reproduce it too.

        However, I fixed the two potential NPEs Aleks' log file was showing by adding code checking if the entries are null or not .

        Fixed at revision 898733.

        http://svn.apache.org/viewvc?rev=898733&view=rev

        Pierre-Arnaud Marcelot made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Pierre-Arnaud Marcelot added a comment -

        Version 1.5.3 has been released.
        Let's close this issue.

        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        440d 3h 4m 1 Pierre-Arnaud Marcelot 13/Jan/10 13:03
        Resolved Resolved Closed Closed
        98d 19h 3m 1 Pierre-Arnaud Marcelot 22/Apr/10 09:07

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Aleks M
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development