Details

      Description

      request for multi-language GUI for Apache Directory Studio.
      I suggest to use Apache commons-configuration components to read key-value based multi-language strings in XML format. Each language has a XML file.
      I can translate from English to Chinese.
      Please do not use Java properties files for multi-language, XML is better for modifing.
      I am sorry that I do not familliar with SWT. If this project is based on Swing, I can finished this part by myself.

        Issue Links

          Activity

          Jacklondon Chen created issue -
          Felix Knecht added a comment -

          I'd suggest doing it the proposed way [1] even if it's *.properties based. Why is xml better?

          [1] http://www.eclipse.org/articles/Article-Internationalization/how2I18n.html

          Felix Knecht made changes -
          Field Original Value New Value
          Link This issue is duplicated by DIRSTUDIO-173 [ DIRSTUDIO-173 ]
          Pierre-Arnaud Marcelot added a comment -

          I'd also suggest we use property files, as this is the most standard way for doing this in usual Java projects and Eclipse plugins.

          Felix, I saw you started translating Studio in German.
          That's awesome!

          Pierre-Arnaud Marcelot made changes -
          Summary request for multi-language GUI Request for multi-language GUI
          Felix Knecht added a comment -

          Some hopefully usefull hints:

          • 'Normall' only the content from plugin.properties/messages.properties needs to be translated and be put into a file specific to your language (e.g. plugin_de.properties for German or plugin_de_CH.properties for Swiss German).
          • You only need to translate what is different to the origin file. If a property isn't found in your translation file it's falling back to the main *.properties file.
          • Use eclipse' PropertyEditor in the 'Properties' View to edit the values. This will do the Unicode encoding stuff for you and prevent you from having afterwards strange characters within your translation.
          Felix Knecht added a comment -

          The situation may exist, that no translation can be done, meaning all the external strings are taken from the messages.properties file.
          IMO it would be preferable to add just an empty language properties file to indicate that there are not special translations for this language, but that the translator has thought about translating.
          WDOT?

          Felix Knecht added a comment -

          IMO most of the strings to translate are now externalized. Translations can be started
          Most easy way is probably to copy the messages.properties file (containing the external strings), delete entries where no translation is needed and translate the other entries to your needs.

          Pierre-Arnaud Marcelot added a comment -

          Hi Felix,

          Answer to your post on 27/Nov/08 01:31 AM:
          I totally agree. This looks like a good process.

          Answer to your post on 28/Nov/08 04:06 AM:
          That's awesome!
          Thanks a lot, really a lot, for having extracted these strings and providing the german translation.
          I'll give it a try for the french version.

          I propose we launch a thread on the users ML asking for a contribution for other languages.
          WDOT?

          Felix Knecht added a comment -

          Well it's not perfect, but a start .
          Also the German translations are not complete yet ... Good luck when transating to French!

          +1 to start the thread. The problem is that there will be the need of some kind of coaching and ATM I don't see much I can spend on this (that's also I can't finish the German translations for the moment...). I'm sorry about this.

          Jacklondon Chen added a comment -

          to Felix Knecht,
          .xml file can be modified by non-programmer end users. While .properties file can only be modified by Java programmers.
          It seems eclipse plug-in only support multi-language with .properties files.
          I have finished some projects with multi-language based on .xml files. And the translation task is been done by a professional translation company. I think this is a good working-model.
          Generally, multi-language task can be implement in following ways:
          a. plain text files, such as .xml files, .ini files,
          b. encoding text files, such as .properties files.
          c. binary files. such as mysql errmsg.sys
          d. database tables.

          If we use plain text files, end user will easily add new language based on English language files with a text editor.
          And database tables make it easy to query if there is any missing, for example, from 1.0 to 1.1, english langauge add 50 items, while chinese add 44 items. SQLdatabase make it easy to find out.

          for .properties, I don't think there is any advantages for multi-langauge.

          Jacklondon Chen added a comment -

          And .xml file multi-language normally been put into an application folder, not inside .jar files. It seems not good here for Eclipse plug-in.

          Stefan Seelmann made changes -
          Affects Version/s 1.3.0 [ 12313309 ]
          Fix Version/s 1.4.0 [ 12313402 ]
          Pierre-Arnaud Marcelot made changes -
          Component/s studio-apacheds [ 12312429 ]
          Component/s studio-apacheds-configuration [ 12311753 ]
          Component/s studio-connection [ 12311913 ]
          Component/s studio-ldapbrowser [ 12311538 ]
          Component/s studio-ldifeditor [ 12311948 ]
          Component/s studio-rcp [ 12311521 ]
          Component/s studio-schemaeditor [ 12311522 ]
          Pierre-Arnaud Marcelot made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Pierre-Arnaud Marcelot added a comment -

          Apache Directory Studio version 1.4.0 has been released.

          Pierre-Arnaud Marcelot made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          190d 22h 26m 1 Pierre-Arnaud Marcelot 02/Apr/09 09:26
          Resolved Resolved Closed Closed
          231d 7h 22m 1 Pierre-Arnaud Marcelot 19/Nov/09 15:48

            People

            • Assignee:
              Unassigned
              Reporter:
              Jacklondon Chen
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 672h
                672h
                Remaining:
                Remaining Estimate - 672h
                672h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development