Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-396

Custom LDAP attributes not shown in entry editor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.4.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      We have extended the standard LDAP schemas with custom attributes. The DS Entry Editor does not display the custom attributes in search results (JXplorer does display them OK), they are only visible in the Outline. But the Outline does not allow to put the attribute names or values into the clipboard from Outline.

      Custom attributes should be supported by the Entry Editor, too.

        Activity

        Emmanuel Lecharny added a comment -

        Can you paste one of the custom attribute which does not show up on Studio ?

        Stefan Seelmann added a comment -

        Is it possible that your attributes are operational attributes? Then please make sure you enabled the "Show operational attributes" option: http://directory.apache.org/studio/static/users_guide/ldap_browser/preferences_entry_editor.html

        Jürgen Weber added a comment -

        OK, our LDAP wizard gave me an extract of the schema defining the attributes that do not show:

        Auxiliary Objectclass

        objectclass (1.3.6.1.4.1.25977.1.1.1.2.204 NAME 'RRRechteContainer'
        DESC 'Containerobjekt'
        SUP top
        AUXILIARY
        MAY (rr-teilarbeitsablaufKennungRef $ rr-aktivitaetsKennungRef $ rr-zustaendigkeitsKennungRef ))

        Auxiliary Attribute

        attributetype (1.3.6.1.4.1.25977.1.1.1.1.201 NAME 'rr-zustaendigkeitsKennungRef'
        DESC 'Referenz'
        EQUALITY caseIgnoreMatch
        SUBSTR caseIgnoreSubstringsMatch
        SYNTAX 1.3.6.1.4.1.1466.115.121.1.15)

        Structural Class

        objectclass (1.3.6.1.4.1.25977.1.1.1.2.1 NAME 'RRContainer'
        DESC 'Standard Container'
        SUP top
        STRUCTURAL
        MUST (cn)
        MAY (description $ rr-status)
        )

        objectclass (1.3.6.1.4.1.25977.1.1.1.2.5 NAME 'racfClass'
        DESC 'RACF Resourceklasse'
        SUP RRContainer
        STRUCTURAL
        MAY (cn $ racfResourceMember )
        MUST (racfClass)
        )

        Structural Attribute

        attributetype (1.3.6.1.4.1.25977.1.1.1.1.32
        NAME 'racfClass'
        DESC 'racfClass'
        EQUALITY caseIgnoreMatch
        SUBSTR caseIgnoreSubstringsMatch
        ORDERING caseIgnoreOrderingMatch
        SYNTAX 1.3.6.1.4.1.1466.115.121.1.15)

        Stefan Seelmann added a comment -

        Hi Jürgen,

        have you checked if the "Show operational attributes" option is enabled? I am pretty sure that's the cause.

        Regards,
        Stefan

        Jürgen Weber added a comment -

        Stefan, I'll check. But if this solves the problem, the bug should be changed, as I do not see, why one should check show operational attributes to see custom attributes

        Stefan Seelmann added a comment -

        Yes, Jürgen, you are totally right. We have to change this.

        I have another idea: maybe the modified schema wasn't reloaded correctory? Could you check in the schema browser if your object classes and attributes are present and eventually reload the schema?

        Emmanuel Lecharny added a comment -

        What would be interesting is to look at the schema using Studio, and see if the attributeType have the correct USAGE field (ie, 'user' is experted, but you will likely have something different).

        Then the next step will be to check if we send the attributeType with the correct USAGE field if it's not present (it should default to 'user' in this case), or if the server simply FU the USAGE field.

        BTW, which LDAP server are you using ?

        Thanks !

        Jürgen Weber added a comment -

        In this case the server was the z/OS LDAP server.

        http://publibz.boulder.ibm.com/epubs/pdf/glda2a40.pdf

        Stefan Seelmann added a comment -

        This should be fixed, handling of operational attributes has been changed, see also DIRSTUDIO-427.

        Jürgen Weber added a comment -

        With 1.4 custom attributes are shown.

        Thanks very much for fixing the issue.

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.4.0 has been released.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jürgen Weber
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development