Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.3.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Apache Directory Studio 1.2.0
      ApacheDS 1.5.3 SNAPSHOT

      Description

      If someone creates a partition for ApacheDS and does not add a context entry in the configuration of the server.xml (possible with ApacheDS 1.5.4 and above), it can't be used. A context entry has to be added first with the help of an LDAP add command.

      Unfortunately, this is not possible with Apache Directory Studio 1.2.0, id the DN of the suffix contains more than one RDN. For instance, New Entry does not work for the entry dc=example,dc=com

      I recommend a new menu item called "Add new context entry" or "Add new suffix", which is comparable to the Add entry dialog, but allows the user to provide the complete DN without a parent.

      A highlight would be, if the dialog detects possible values from the namingContexts attribute from the Root DSE. If a new partition has been added to the server.xml, it is listed there. See here for details:

      http://cwiki.apache.org/confluence/display/DIRxSRVx20/1.5.3+Adding+your+own+partition+resp.+suffix

        Activity

        Stefan Seelmann added a comment -

        The menu item and the wizard are the same, there are just some new conditional parts. If you select the "DIT" item or the Root DSE in the browser then the menu item is called "New Context Entry". In the wizard you could enter the comlete DN or select a namingContext value from the drop-down box.

        Fixed here:
        http://svn.apache.org/viewvc?rev=691556&view=rev

        Stefan Zoerner added a comment -

        Thanks for handling this one that fast, Stefan!

        Basically, it works very well. The only thing: If I add a context entry, and select the object classes, it is not possible to add further (optional) attributes, other than the required ones during the entry creation. The buttons for that are disabled in the dialog.

        I have tried the ApacheDirectoryStudio-win32-1.3.0.SNAPSHOT from the website (03-Sep-2008 11:48)

        Stefan Seelmann added a comment -

        You mean in the 4th step (Attributes) the buttonto add an attribute is disabled? Even if you select an attribute in the table? I can't reproduce that. Anyways, I added a fix that the "New Attribute" action is automatically enabled when the 4th step becomes visible.

        Stefan Zoerner added a comment -

        Oups. You are right. If I select one of the required attributes, which are already filled, the buttons become active. Sorry for that. But I would recommend the behavior you have described above (the fix), and I am eager to see it (I will wait for the next nightly build).

        Thanks Stefan!

        Stefan Zoerner added a comment -

        I have tried it out, and it works really fine now.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Stefan Zoerner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development