Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-382

Unable to launch Apache Directory Server with Turkish Regional Settings

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.3.0
    • Component/s: studio-apacheds
    • Labels:
      None
    • Environment:
      Windows XP SP2; J2SE build 1.6.0-b105;

      Description

      I have just installed apache directory server and studio. when I try to connect to the server with studio it tries to connect and stops immediately. I figured out the problem as my regional language settings set to turkish. when I change to english the connection ends up successful. It looks like studio has a problem with upper-case turkish letters.

      1. scenario.doc
        638 kB
        tolga yurdakul
      2. .log
        8 kB
        tolga yurdakul

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        21h 16m 1 Pierre-Arnaud Marcelot 29/Aug/08 09:33
        In Progress In Progress Resolved Resolved
        3h 7m 1 Pierre-Arnaud Marcelot 29/Aug/08 12:40
        Resolved Resolved Closed Closed
        196d 2h 59m 1 Pierre-Arnaud Marcelot 13/Mar/09 14:39
        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Pierre-Arnaud Marcelot made changes -
        Summary Connection Problem to Apache Directory Server with Turkish Regional Settings Unable to launch Apache Directory Server with Turkish Regional Settings
        Pierre-Arnaud Marcelot added a comment -

        Updated title for a better match of the description?

        Pierre-Arnaud Marcelot made changes -
        Resolution Won't Fix [ 2 ]
        Status In Progress [ 3 ] Resolved [ 5 ]
        Pierre-Arnaud Marcelot added a comment -

        It can't be fixed for now... Sorry..

        Pierre-Arnaud Marcelot added a comment -

        I debugged the execution and I was not able to find the bug.

        When the regional setting is set to Turkish, then something stops the exections of the Launch Configuration, which wakes up our listener. This listener then sets the server as 'Stopped'.

        I'm affraid there's nothing we can do for now.

        Perhaps latest Eclipse dependencies will fix this issue.

        In the meantime, I'll resolve this issue as "Won't fix".

        Pierre-Arnaud Marcelot made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Pierre-Arnaud Marcelot added a comment -

        For your info, I managed to reproduce the bug...

        I'm working on finding what's going on...

        Pierre-Arnaud Marcelot made changes -
        Component/s studio-apacheds [ 12312429 ]
        Pierre-Arnaud Marcelot made changes -
        Assignee Pierre-Arnaud Marcelot [ pamarcelot ]
        Fix Version/s 1.3.0 [ 12313309 ]
        Affects Version/s 1.2.0 [ 12312851 ]
        Pierre-Arnaud Marcelot added a comment -

        Thanks, the doc file is perfect.

        It made me realize that you're actually trying to run Apache DS within Studio.

        I'll try this on my Windows box and try to find a fix.

        tolga yurdakul made changes -
        Attachment scenario.doc [ 12389151 ]
        tolga yurdakul added a comment - - edited

        I added a file describing the scenario. the scenario is quite simple.

        It looks like the .log that I have sent before was for something else. I cleared the log today and tried the scenario again but no .log file had been created.

        Pierre-Arnaud Marcelot added a comment -

        Hi Tolga,

        Thanks for opening the Jira issue.

        Can you provide us the complete scenario you're using, so we can reproduce the bug.

        What command are you using, in what order ?

        Thanks a lot!

        Emmanuel Lecharny added a comment -

        Seems to be an Eclipse problem ?

        tolga yurdakul made changes -
        Field Original Value New Value
        Attachment .log [ 12389084 ]
        tolga yurdakul created issue -

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            tolga yurdakul
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 24h
              24h
              Remaining:
              Remaining Estimate - 24h
              24h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development