Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-378

An attribute name containing an underscore ("_") is split in two when used in "Returning Attributes" field of the "Search" dialog

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.3.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Windows XP > Eclipse 3.4, querying an Oracle OID server.

      Description

      Using an attribute name containing an underscore ("_") in the "Returning Attributes" field of the "Search" dialog results in that name being split into several parts. Example: "user_id" will become "user" and "id". As a result both attributes will be blank as they do not exist.

        Activity

        Martynas Brijunas added a comment -

        Hi Stefan,

        I have tried the latest nightly build (Aug 27) and I can confirm that the problem is solved. I have asked to list 3 attributes with an underscore and it dutifully did. Thank you.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Martynas Brijunas
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development