Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-331

Instant error when importing schema in a new schema-project

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.5.0
    • Component/s: studio-schemaeditor
    • Labels:
      None
    • Environment:
      Windows XP+SP2, SunJava 1.6.0. Update 5
      also Windows XP+SP3, SunJava 1.5.0 Update 14
      also Ubuntu 8.04 with SunJava 1.5.0_15

      Description

      We got plenty of errors everytime we imported a openldap-scheme. We did following steps:

      1. Open Apache Studio
      2. Open schema-editor view
      3. Create a new schema-project (in this step don't import any schema)
      4. After creating the new project, do a right-click and choose "import". Choose "open ldap".
      5. Import "core" schema

      After importing the core schema, plenty of errors appears in the problems-view. We got the same problems on the windows box and
      on a ubuntu virtual machine. But the strange thing is, we got at least one installation running on a ubuntu machine (no virtual machine) without
      any problems. The schema-editor is not usable in this state.

      1. core.schema
        15 kB
        Marc
      2. ads_schema_errors.jpg
        77 kB
        Marc
      3. ads_used_openldap_schema.jpg
        85 kB
        Marc

        Activity

        Emmanuel Lecharny added a comment -

        Can you just attach one of the imported schema which cause a problem ?

        We also would be interested in having a copy of the errors you get.

        Marc added a comment -

        Here's the core.schema i've exported directly from ads. I attach two screenshots, so you can see what's going on.

        Marc added a comment -

        After trying some things, i found out that the problems also occur on that ubuntu machine. A workaround for this
        is just to ignore the errors. The custom schema files are working well on the ldap-server itself.

        Emmanuel Lecharny added a comment -

        In order to reproduce the error, the step #5 should be "import the core.schema file", instead of selecting the core schema into the proposed schema to import.

        Importing the schema from the proposed list is also a pretty correct workaround.

        Stefan Seelmann added a comment -

        The critical thing is to add the "system" core schema. It includes the built-in attributes (name, cn, uid, etc.) as well as all syntaxes and matching rules. However also when including the "system" schema there are errors because some syntaxes and matching rules are missing. I'll update the schema files from current OpenLDAP 2.4.

        Stefan Seelmann added a comment -

        Added the latest schema including syntaxes and matching rules:
        http://svn.apache.org/viewvc?rev=823443&view=rev

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory studio version 1.5.0 has been released.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Marc
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development