Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Tried w/Eclipse 3.3.2 on:
      - Mac OS X w/1.5.0_13
      - Linux x86 w/1.6.0_01

      Description

      I'm attempting to do a batch operation:

      1. Select ou=people
      2. Search for uid=*
      3. Modify
      4. add objectClass shadowAccount
      5. Only option is to put in LDIF file; Execute is grayed out
      6. Once the LDIF is generated, I am unable to save it or do anything else with it.

      I'm unable to verify if this problem happens in the RCP version of Studio due to DIRSTUDIO-321.

        Activity

        Stefan Seelmann added a comment -

        The batch operation feature isn't complete yet.

        Why aren't you able to save it? Do you get an error message? Could you please check your <workspace>/.metatdata/.log file for an exception?

        If your LDIF is generated you should be able to run it against the directory. Does that work?

        Stefan Seelmann added a comment -

        As already written I can't reproduce the error.

        Jigs B added a comment -

        Hello Stefan, was using 1.0.x for a couple of years and upgraded today to 1.5.x hoping that the "Execute online" teaser will finally come to life. But I guess not. Can you explain why it has been a place holder all these years !? Any technical reason !?

        Otherwise, love this product and almost everything from ASF. Thank you for your effort & support. Keep it up.

        Thanks
        -Jigs

        Jigs B added a comment -

        Hello Stefan, was using 1.0.x for a couple of years and upgraded today to 1.5.x hoping that the "Execute online" teaser will finally come to life. But I guess not. Can you explain why it has been a place holder all these years !? Any technical reason !?

        Otherwise, love this product and almost everything from ASF. Thank you for your effort & support. Keep it up.

        Thanks
        -Jigs

        Pierre-Arnaud Marcelot added a comment -

        Hi Jibs,

        I don't think there's any technical reason why this feature isn't implemented yet.
        I guess it's probably because of a lack of time and that we've been busy elsewhere in the code (and in other projects too).

        Can you at least confirm that the generation of the LDIF file works for you (it worked for me), and you're only reopening the issue to indicate that the "Execute Online" feature is still missing (grayed out)?

        Thanks!

        Pierre-Arnaud Marcelot added a comment -

        Scheduling this for 2.0.0, so we don't forget to fix that...

        Jigs B added a comment -

        Thanks Pierre, yes the save to LDIF and then re-import the same works for us but was hoping to avoid that couple of extra steps. It seems it was not working for the OP who opened the ticket. I re-opened the case to just check on the grayed out "Execute online"

        So what is the ETA on 2.0 !?

        Pierre-Arnaud Marcelot added a comment -

        Oh sorry, I didn't notice you were not the initial reporter.

        In that case, I'm going to create a separate issue.

        Good to know that the generated LDIF was perfectly imported.
        It should not be too complicated to combine the two actions and link it to the "Execute Online" button.

        The ETA for 2.0 is still unclear. I think we would be able to deliver a few milestone versions during the summer and more formal releases like betas or RCs later in the year.

        Pierre-Arnaud Marcelot added a comment -

        Jibs, I hope you don't mind, I assigned you as the reporter for DIRSTUDIO-736 (Implement the "Execute Online" button of the BatchOperationWizard).

        Pierre-Arnaud Marcelot added a comment -

        Moving back to a "Cannot Reproduce" resolution.

        Pierre-Arnaud Marcelot added a comment -

        Removed fix version.


          People

          • Assignee:
            Unassigned
            Reporter:
            Allen Wittenauer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development