Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-319

LDAP Browser creating new entry becomes empty and unusable in Windows Vista after certain actions

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Windows Vista SP1 32Bit, 4GB RAM, Intel Core 2 Duo E6750 CPU @ 2,66GHz
      SUN Java JDK 1.5.0_15 and SUN Java JDK 1.6.0_05

      Description

      Following happens:
      1. Starting Directory Studio
      2. Browsing to tree position cn=users,cn=cms,dc=applications
      3. Right click "new entry" and select "Inetorgperson"
      4. fill out all needed information
      5. finish creation
      6. browse to cn=rollen,cn=cms,dc=application
      7. Right click "new entry" and select "groupOfUniqueNames"
      8. fill out all needed information
      9. finish creation
      10. repeat step 2 and 3
      11. now the overlayed window becomes complete empty. can only be cancelled by clicking on right corner "x"
      12. underlaying Directory Studio window becomes inaccessible, too. only way is to kill the task

      1. DIRSTUDIO-319.jpg
        235 kB
        Markus Pohle
      2. threaddump.txt
        43 kB
        Markus Pohle

        Activity

        Stefan Seelmann added a comment -

        We haven't tested Studio on Vista yet. It sounds like we still have problems with handles and GDI objects. I will raise it to a blocker.

        Pierre-Arnaud Marcelot added a comment -

        I tried to reproduce it on Vista in a Parallels Desktop VM on Mac using you scenario and I was not able to...

        Here's my set up:

        • Windows Vista SP1 32Bit,
        • 1 Go Ram (dedicated to the VM)
        • Intel Core 2 Duo 2,33 GHz
        • Sun JRE 1.6.0_06
        • Apache Directory Studio 1.1.0

        Does your scenario always have the same action on Studio, and makes it completely inaccessible ?

        Thanks.

        Markus Pohle added a comment -

        This is how my LDAP Directory Studio Version 1.1.0.v20080303 looks like after trying to create the second cn-Entry as described in my error report.

        Markus Pohle added a comment -

        Hello Pierre,

        the scenario always has the same action as described above and make my ldap studio look like the screenshot above. after first appearance it is possible to just close the popup window and studio is accessible again. but on second appearance studio itself becomes inaccessible and the only way is to kill the task.

        i have tried different java version and also tried with and without the new vista style - makes no difference for me. sooner or later ldap studio shows tha described behaviour.

        i have not tried to reproduce that in a virtual machine but can try it in vmware workstation 6, vmware server 1.0.5 and virtual box 1.6 if you see a need for that.

        greetings
        markus

        Pierre-Arnaud Marcelot added a comment -

        Thanks for these informations Markus.

        Could you give us the "Modifications logs" of one of the failing scenarios ? Maybe there's some value you are using that makes the UI go weird...

        Thanks

        Markus Pohle added a comment -

        Hi there... the modification logs are the following... but: the error happens always right after when i created the second uid=test.0002 entry. then the popup window looks like in my screenshot above.

        #!RESULT OK
        #!CONNECTION ldap://cmsldap1.douglas-informatik.de:389
        #!DATE 2008-06-17T16:17:08.293
        dn: uid=test.0001,cn=users,cn=cms,dc=APPLICATIONS,dc=DOUGLASHOLDING
        changetype: add
        objectClass: inetOrgPerson
        objectClass: organizationalPerson
        objectClass: person
        objectClass: top
        givenName: test0001
        uid: test.0001
        userPassword:: dGVzdA==
        sn: 0001
        cn: test

        #!RESULT OK
        #!CONNECTION ldap://cmsldap1.douglas-informatik.de:389
        #!DATE 2008-06-17T16:17:30.001
        dn: cn=test.0001,cn=rollen,cn=cms,dc=APPLICATIONS,dc=DOUGLASHOLDING
        changetype: add
        objectClass: groupOfUniqueNames
        objectClass: top
        uniqueMember: uid=test.0001,cn=users,cn=cms,dc=APPLICATIONS,dc=DOUGLASHOLDING
        cn: test.0001

        #!RESULT OK
        #!CONNECTION ldap://cmsldap1.douglas-informatik.de:389
        #!DATE 2008-06-17T16:18:03.674
        dn: uid=test.0002,cn=users,cn=cms,dc=APPLICATIONS,dc=DOUGLASHOLDING
        changetype: add
        objectClass: inetOrgPerson
        objectClass: organizationalPerson
        objectClass: person
        objectClass: top
        givenName: test0002
        uid: test.0002
        userPassword:: dGVzdA==
        sn: 0002
        cn: test

        Pierre-Arnaud Marcelot added a comment -

        Thanks for the answer.

        I can see from your logs that you managed to create 2 users and 1 group, but the creation of the 2nd group failed. Is that right?

        I tried to follow what you did and I was able to create 2 users and 2 groups with success.
        Here are my logs:
        #!RESULT OK
        #!CONNECTION ldap://localhost:10389
        #!DATE 2008-06-17T16:41:37.861
        dn: uid=test.0001,ou=users,dc=example,dc=com
        changetype: add
        objectClass: inetOrgPerson
        objectClass: organizationalPerson
        objectClass: person
        objectClass: top
        givenName: test0001
        uid: test.0001
        sn: 0001
        cn: test

        #!RESULT OK
        #!CONNECTION ldap://localhost:10389
        #!DATE 2008-06-17T16:42:19.905
        dn: cn=test.0001,ou=groups,dc=example,dc=com
        changetype: add
        objectClass: groupOfUniqueNames
        objectClass: top
        uniqueMember: uid=test.0001,ou=users,dc=example,dc=com
        cn: test.0001

        #!RESULT OK
        #!CONNECTION ldap://localhost:10389
        #!DATE 2008-06-17T16:43:19.164
        dn: uid=test.0002,ou=users,dc=example,dc=com
        changetype: add
        objectClass: inetOrgPerson
        objectClass: organizationalPerson
        objectClass: person
        objectClass: top
        givenName: tes0002
        uid: test.0002
        sn: test
        cn: 0002

        #!RESULT OK
        #!CONNECTION ldap://localhost:10389
        #!DATE 2008-06-17T16:43:58.775
        dn: cn=test.0002,ou=groups,dc=example,dc=com
        changetype: add
        objectClass: groupOfUniqueNames
        objectClass: top
        uniqueMember: uid=test.0002,ou=users,dc=example,dc=com
        cn: test.0002

        I'm affraid, it'll be difficult for us to reproduce this bug.

        What directory server are you using?

        Pierre-Arnaud Marcelot added a comment -

        One more thing, have you tried to resize the wizard window (this action forces the wizard to refresh the UI) ?

        Stefan Seelmann added a comment -

        Markus,

        could you please provide us a thread dump? Please start Studio from command line
        java -jar plugins\org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar > threaddump.txt

        then when this error happens you could use SendSignal.exe to create the threaddump.
        http://www.latenighthacking.com/projects/2003/sendSignal/

        Thanks,
        Stefan

        Markus Pohle added a comment -

        Threaddump from my ldap studio

        Markus Pohle added a comment -

        Hi Pierre,
        I have, for sure, tested to resize the wizard window. that was what i did first. but with no success.

        Stefan Seelmann added a comment -

        Markus, thanks for the thead dump. The main thread hangs in "org.eclipse.swt.internal.win32.OS.WaitMessage(Native Method)" so I would assume that this may be a SWT bug.

        As we are not able to reproduce this bug I would suggest that we release a 1.2.0 RC1 soon. It includes the newest SWT build 3.3 049d and some problems with leaking GDI objects are fixed. Hopefully your problem is solved then

        Pierre-Arnaud Marcelot added a comment -

        Hi Markus,

        If you have a minute, could you please test if there is still this bug with the testing packages for Apache Directory Studio 1.2.0 RC1 ?

        They are available here: http://people.apache.org/~pamarcelot/Apache_Directory_Studio_1.2.0.SNAPSHOT/

        Thanks a lot.

        Pierre-Arnaud

        Markus Pohle added a comment -

        Did tests with Apache Directory Studio 1.2.0 RC1 like Pierre asked me for
        Works fast and smooth and the error isn't reproduceable anymore

        For me looks like the problem is fixed!

        Pierre-Arnaud Marcelot added a comment -

        Awesome !!!

        Thanks a lot Markus.

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio 1.2.0 has now been released.

        Let's clean Jira and close this issue.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Markus Pohle
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development