Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-282

Save failed: null, when adding an attribute to a class, if attribute is also open in gui

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.5.0
    • Component/s: studio-schemaeditor
    • Labels:
      None
    • Environment:
      ubuntu 7.10, -vm /usr/lib/jvm/java-1.5.0-sun/bin/java, eclipse.buildId=M20070212-1330

      Description

      If I have a created an attribute and its open in the GUI and I add the attribute as (optional) attribute to a created object class and save the class, the attribute gets a modified * symbol next to its name (used by is changed, but it's not change which needs to be saved I think).
      But if I then try to save the attribute it says "Save Failed:null". So I have to close it without saving.

      If the attribute is not open in the editor and open it afterwards everything is fine, and the "used by" tab is correctly filled in.

        Activity

        Hide
        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.5.0 has been released.

        Show
        Pierre-Arnaud Marcelot added a comment - Apache Directory Studio version 1.5.0 has been released.
        Hide
        Stefan Seelmann added a comment -

        This was fixed with DIRSTUDIO-497.

        Show
        Stefan Seelmann added a comment - This was fixed with DIRSTUDIO-497 .

          People

          • Assignee:
            Unassigned
            Reporter:
            Wessel Louwris
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development