Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-249

Modification Logs view does not display request controls, if sent to the server

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.1.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      Client:
      Windows XP SP 2
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
      Apache Directory Studio 1.0.1

      Server:
      Solaris 9 (SPARC)
      IBM Tivoli Directory Server 6.0

      Description

      Although it is probably a more general defect, here is the scenario where I figured it out.
      If a server supports the Tree Delete control (OID 1.2.840.113556.1.4.805), Studio deletes subtrees of entries with the help of it, which is quite nice.
      Unfortunately, the Modification Logs view does not display in the LDIF that the controls has been used. It only shows the deletion of the parent entry of the tree, like

      #!RESULT OK
      #!CONNECTION ldap://degas:389
      #!DATE 2007-12-09T20:02:45.359
      dn: ou=parent,dc=TIVOLIDS,dc=DEGAS
      changetype: delete

      In order to replay the file in the logs, inclusion of the control is required, like

      dn: ou=parent,dc=TIVOLIDS,dc=DEGAS
      control: 1.2.840.113556.1.4.805 true
      changetype: delete

      See RFC 2849 (http://www.faqs.org/rfcs/rfc2849.html) for details.

        Activity

        Stefan Seelmann added a comment -

        Here is the class responsible for doing the logs: http://tinyurl.com/2ebdyc

        There is already an TODO in the class. The cause why it isn't implemented yet is because I am not sure about the encoding of control values. Of course for the Tree Delete Control it is quite easy because it doesn't contain a control value.

        Stefan Seelmann added a comment -

        Fixed here: http://svn.apache.org/viewvc?rev=602749&view=rev

        Note: When JNDI sends an implicit ManageDsaIT control this one isn't logged, see DIRSTUDIO-247

        Stefan Zoerner added a comment -

        I have tested with my Treed Delete Control example against IBM Tivoli DS, and it looks nice. Well done, StefanS!


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Stefan Zoerner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development